Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Is it possible to install Ubuntu on the new Lenovo Yoga 2 Pro? I have checked the Lenovo compatibility lists on the Ubuntu site, but no new entries have been created yet for this model (released mid-October).

share|improve this question
I put a lot of effort to write a complete Installation guide as answer below. I collected from various sources how to install Ubuntu on Lenovo IdeaPad Yoga 2 Pro, maybe you would like to accept that one with the green hook? –  rubo77 Sep 7 '14 at 6:49
it's time to add an entry for Ubuntu 15.04 (my WiFi is still rellying on externally installed lwfinger's driver). –  vak Apr 25 at 11:07

19 Answers 19

up vote 37 down vote accepted

just bought (last week) one (yoga 2 pro - i7 - 8 GB ram - 256 SSD) and have installed ubuntu 13.10.

It comes with a small button on the side of the power button to enable the BIOS edit and boot sequence... When you press it, the computer powers up with the config menu. Then you have to edit the BIOS to unsecure UEFI mode. It was really easy.

To boot the ubuntu you have to edit the grub's boot line before the quiet parameter, adding: acpi_backlight=vendor

and after installing ubuntu, in the /etc/default/grub file, you have to add the same acpi conf in the 11th line:

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor quiet splash"

and execute the: sudo update-grub2 command

and that's it...

  • at first, wireless was hard blocked and I tried out everything to enable it (rfkill unblock, kernel upgrade to 3.12, and nothing worked)

In order to use it without wireless, I bought the J5 usb 3.0 gigabit ethernet adapter... it works without any configuration.

I found some posts online saying that they have solved this by reinstalling windows, unblocking the wireless card via software, and then going back to linux. I removed all partitions and I am not planning to reinstall windows.

The funny thing was that iwlist wlan0 scan worked... so that was very strange...

Today I installed wicd to replace the network manager and the wireless start working !!!!!! the only thing that was needed was to copy the resolv.conf from the ubuntu location to /etc (replacing the symbolic link)

cp /run/resolvconf/resolv.conf /etc/

Also the brightness function key is not doing nothing... but I don't care about that... :-)

share|improve this answer
replacing /etc/resolv.conf is not recommended. See… –  guntbert Oct 31 '13 at 18:03
See this for more info on fixing the wireless issue:… –  Anake Nov 1 '13 at 15:28
i'm assuming that the screen resolution, etc., worked out just fine with the system? –  Dan G Nov 2 '13 at 11:10
Dan G: the screen resolution goes up to 3200x1800 (and the image is sharp), the sound is also working, I use an mini HDMI to VGA adapter (for use with projectors) and it is working fine, webcam is working (I am having trouble with the webcam in skype, but it is working with other programs)... and I didn't mention before: I am using ubuntu 13.10 64 bits. Today, using Anake's post, I blacklisted the ideapad_laptop module and the network manager started working. With this, I could return the resolv.conf as a link and the wireless is working !!! Thanks Anake and Guntbert !!!! –  Deco Nov 2 '13 at 15:52
@rubo77, Ok, many thanks for the info! –  Samuel Lampa Sep 8 '14 at 7:49

How to install Ubuntu on Lenovo IdeaPad Yoga 2 Pro

I got a Yoga 2 pro - i5 - 8 GB ram - 256 SSD (I first have installed Ubuntu 13.10 32bit (tried 64bit too, but crashes with kernel panic!), but I guess now Ubuntu 14.04 64bit will just run fine.)

These are the steps I had to do to install Ubuntu:

1. Prepare the installation

  1. I started Windows and resized the Windows partition so I got 100GB free.
    (If needed: here you find a detailed inscruction with screenshots at the end come back here and continue with step 4)

  2. It comes with a small button on the side of the power button to enable the BIOS edit and boot sequence... When you press it, the computer powers up with the config menu. Then you have to edit the BIOS to unsecure UEFI mode.

  3. choose "Legacy Boot"

  4. To boot Ubuntu you have to edit the grub's boot line before the quiet parameter, adding: acpi_backlight=vendor
    (I installed from an USB-stick, created with UNetbootin. In The UNetbootin boot menu press [TAB] to edit options and add that parameter to the boot line.)

  5. Start Ubuntu from USB (or external CD-drive) and press "Try Ubuntu"

2. Enable WiFi and install

When Ubuntu is started from USB, open a console to enable WiFi with sudo rmmod ideapad_laptop. Then connect to a WiFi Network and Install Ubuntu

3. Fix wireless card

After reboot everything was fine (no need to adjust grub any further) The only problem left was, that up to now I had to enable WiFi after each system start with

sudo rmmod ideapad_laptop
sudo service network-manager restart

so I added that to the modprobe blacklist with:

sudo su  
echo '#added to enable WiFi on Yoga 2 Pro'>>/etc/modprobe.d/blacklist.conf   
echo 'blacklist ideapad_laptop'>>/etc/modprobe.d/blacklist.conf

4. Enlarge Fonts

Now in Ubuntu In 14.04 with Unity everything works fine. Also, it seems like Ubuntu is adopted better to touch-screens. I only had to adapt the Screen DPI in System Settings->"Displays"->"Scale for menu and title bars" to 2.0 + Settings Screenshot
If you use Pidgin, see how to Adapt Ubuntu to a high-DPI resolution screen

5. Adjust Firefox to the high resolution touchscreen

Follow the instructions here:
Adjust Firefox and Thunderbird to a High DPI touchscreen display (retina)

(There is no such thing as zoom with two fingers, but a simple thing already works: You can select active and move the window around with a three finger touch)

Alternative: use Chrome. I tested it in Chrome Version 41.0.2272.76 Ubuntu 14.10: there the touchscreen works fine as expected even pinch to zoom works fine and all menues are the correct size.

6. Adjust the trackpad on Lenovo Yoga 2 Pro

Now adjust the jumpy trackpad and lack of middle button Edit the file /usr/share/X11/xorg.conf.d/50-synaptics.conf and edit the "touchpad catchall" section, so it will look like this:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    # This option is recommend on all Linux systems using evdev, but cannot be
    # enabled by default. See the following link for details:
    MatchDevicePath "/dev/input/event*"

    Option "FingerLow"              "46"
    Option "FingerHigh"             "46"
    Option "ClickFinger1"           "1"
    Option "ClickFinger2"           "2"
    Option "ClickFinger3"           "3"
    Option "TapButton1"             "1"
    Option "TapButton2"             "3"
    Option "TapButton3"             "2"
    Option "AreaBottomEdge"         "85%"
    Option "SoftButtonAreas"        "60% 0 85% 0 40% 60% 85% 0" # Btn2 LRTB - Btn3 LRTB
    Option "EmulateMidButtonTime"   "75"

(source: )

7. Add Screen rotation support on Lenovo IdeaPad Yoga

Since the Screen doesn't turn when you turn the laptop, create the script /usr/local/bin/ from

in System Settings -> Keyboard -> Shortcuts:

  • Assigned Alt+F5 to the command /usr/local/bin/
  • and Alt+Shift+F5 /usr/local/bin/ -n

add rotate screen to keyboard shortcuts

To be able to manually turn the screen from the launcher add a .desktop-file like described here

Note: there was a problem that seems to be solved by the newer kernel by now Lenovo Yoga 2 Ubuntu 14.04 occasionanal blank screen

8. configure larger font on tty console

sudo dpkg-reconfigure console-setup

leave all settings as they are but the last one, where you can chose the size.

9. Optional: Enable some extra power save settings

If you want to dim the screen brightness to 50% on each startup:

 sudo apt-get install xbacklight

Then add this command to your startup programs (gnome-session-properties): xbacklight -set 50

To enable all possible Power save settings, install powertop:

apt-get install powertop

Edit your rc.local startup-script with sudo gedit /etc/rc.local so the end part looks like this:

# By default this script does nothing.

# tune all power save settings to >good<
powertop --auto-tune
# all power save settings are fine but the one for the touchpad
# disable powertop >good<-setting for touchpad 
echo 'on' > '/sys/bus/usb/devices/2-7/power/control'

# optional disable bluetooth and wifi on each start 
# this can always be re-enabled in the top appletts if you need it

# disable bluetooth at start:  (uncomment the following line)
#rfkill block bluetooth

# disable wifi at start: (uncomment both following lines)
#sed s/^WirelessEnabled=true/WirelessEnabled=false/ -i /var/lib/NetworkManager/NetworkManager.state
#rfkill block wifi

exit 0

This is just a suggestion, there might show up some problems with WiFi, using the powersave function set by powertop: sometimes my wirelesss card stopped working, so I disabled the option powertop --auto-tune in rc.local for now and disabled the 11n extension with the following:

sudo su
echo "options iwlwifi 11n_disable=1" >> /etc/modprobe.d/iwlwifi.conf

(You need to reboot after those changes)

But I am still investigating this...

10. more Optional Configurations:

  • Since the battery time is several days in suspend mode, you could set the power-button option to 'suspend' with gsettings set org.gnome.settings-daemon.plugins.power button-power 'suspend'
  • The resolution in grub is really tiny and therefore somewhat slow, this can be solved by making your Grub boot menu pretty

11. Additional useful Hardware for Lenovo IdeaPad Yoga 2 Pro:

I got a "HooToo HT-UE01 USB 3.0 HUB 3-Port with RJ45 10/100/1000 Gigabit Ethernet LAN" that works fine (tested on Ubuntu 32bit) on my Yoga 2 Pro

12. Only problems left:

share|improve this answer
Thanks! 4. and 5. have been helpful for my Dell XPS 15 9530 that has the same resolution and high DPI. :) –  Yann Dìnendal Aug 16 '14 at 20:55
Awesome! I didn't need to do the grub acpi_backlight stuff. My middle button touchpad is being overwritten somewhere. I can see it get set in /var/log/x11. I had to create a script for that. –  Eric Johnson Aug 31 '14 at 21:31
@EricJohnson: how exactly did you solve this? Can you post your script? Atm I solved it with the workaround linked in section 6: –  rubo77 Sep 1 '14 at 4:17
@rubo77 your solution is better than mine. I just put it in my .bashrc. I was looking for that startup applications dialog. Thanks for that. –  Eric Johnson Sep 1 '14 at 21:56
I fixed the wireless problem by changing the boot mechanism to grub-efi, see –  rubo77 Jan 21 at 11:38

I would just like to add to the rest of these answers that you can simply get wireless working with the command

sudo rmmod ideapad_laptop

You can have this persist by adding ideapad_laptop to a blacklist, but this may remove some compatibility (although I have yet to run into these problems).

share|improve this answer
What does this accomplish? I'm trying to get wireless working and I'm working in the dark. What is ideapad_laptop and why is it holding things back? –  Amanda Jun 25 '14 at 18:09

How to install Kubuntu on Lenovo IdeaPad Yoga 2 Pro

I have installed Kubuntu 13.10 32bit just now (tried 64bit too, but crashes with kernel panic!) and these are the steps I had to do to install Kubuntu:

  1. I started Windows and resized the Windows partition so I got 100GB free.
    (If you plan to attach a Hi-Res monitor, you should install PowerStrip on Windows to get the monitor running there and get the correct Linux Modeline Parameter for your monitor.)

  2. It comes with a small button on the side of the power button to enable the BIOS edit and boot sequence... When you press it, the computer powers up with the config menu. Then you have to edit the BIOS to unsecure UEFI mode.

  3. I chose "Legacy Boot"

  4. To boot Kubuntu you have to edit the grub's boot line before the quiet parameter, adding: acpi_backlight=vendor
    (I installed from an USB-stick, created with UNetbootin. In The UNetbootin boot menu press [TAB] to edit options and add that parameter to the boot line.)

  5. Run KDE from USB pressing "Try Kubuntu". You have to enable WiFi with sudo rmmod ideapad_laptop
    (for an easier handling during install adjust the speed of the touchpad somewhat slower: Settings->"Input Devices" set "Cursor Motion"->"Acceleration Factor" to 0.02 and set the Font dpi in Settings->"Appearance"->Fonts to 250 dpi).
    Then I chose "Install KDE".
    In the partitioning menu I chose manual partitioning and created two partitions:

    1. 100 MB for a special partition that is needed for booting (not a /boot partition but some special type: "biosgrub" called "Reserved BIOS boot area")
    2. 100GB for root / as ext4
    3. swap is not needed with 8GB RAM, (but if needed, you can add a swap as file later)
  6. I connected to a WiFi Network

  7. After reboot everything was fine (no need to adjust grub any further) The only problem left is, that I have to enable WiFi after each system start with sudo rmmod ideapad_laptop so I added that to the modprobe blacklist with:
    sudo su
    echo '#added to enable WiFi on Yoga 2 Pro'>>/etc/modprobe.d/blacklist.conf
    echo 'blacklist ideapad_laptop'>>/etc/modprobe.d/blacklist.conf

  8. Since everything is really tiny now, I adjusted some Font settings:

    1. Set the dpi in Settings->"Appearance"->Fonts to 250 dpi and log out and in again.
    2. Adjust Firefox and Thunderbird to a High DPI touchscreen display (retina)

    3. Adjust the height of the KDE-Controllbar at the bottom with the button on the right to the desired height, then all icons grow with the height

  9. To attach my external high resolution monitor I tried to connect Crossover High Res. Monitor to Intel HD Graphics 4400 , but the monitor doesn't work yet.
    Another Monitor with FullHD resolution works fine, but using it as dual monitor is hard, cause on that screen now everything is huge. Maybe it will be possible to have two different DPI configurations for two different screens

  10. Boot to Windows 8.1 again:
    In this setup grub doesn't show Windows 8.1 in the list. But it still easy: if you want to enter your Windows partition, you have to use the small button on the side of the power button (that enables the BIOS edit and boot sequence): there you can still boot to Windows

  11. I defined the font to 230 dpi so everything looks fine (everything but some apps that are running in java.)

  12. Some problems are still open:

13. Finally after some days the window decorations in KDE were all gone! And I couldn't configure them back. So I decided to apt-get install ubuntu-desktop ;P.

So I continued How to install Ubuntu on Lenovo IdeaPad Yoga 2 Pro

share|improve this answer

Just bought a Lenovo Yoga Pro 2, i5, 256MB SSD. This is what I did for 14.10, simpler than was mentioned above:

  1. On different PC download Ubuntu 14.10 and use "Startup Disk Creator" to create USB boot
  2. Insert this Ubuntu USB boot in USB 2.0 (right one)
  3. Press power button to start YP2, and hold Fn+F2
  4. Go into BIOS,
  5. Go to Boot Menu. Using F6 raise "EFI USB Device" to first position (no more, that is all... Ubuntu is EFI ok, all fine! )
  6. Just as I like it: Go to Configuration Menu and Disable Hotkey mode, because I like Fn keys to function directly
  7. F10 to save and exit. Let YP2 reboot

    ( First I install Live... all seems to work great! )

  8. Select from Ubuntu USB boot options (very small print): "Install Ubuntu" ( I do not need any Windows anymore, so no partitioning for me)

  9. The Boot menu appears nicely. Without any problem shows my WIFI and connects ! :)
    1. Select "Erase Disk and Install Ubuntu" ... But then oops... Installer Crashed! "Installer encountered error with copying files to harddisk". It goes on and boots into Live session. Hmmm.. a. I try same on USB 3.0 port; same problem b. I check the downloaded iso with the md5sum, that is ok c. I steal a different USB from my wife and try again..fingers crossed... yes!... It's installing..
    2. Reboot. All good.
    3. Install Updates, Restricted Extra's and report what works and what not here:

A. WIFI Works superb: I get now 144Mbs (2.4GHz only, I know you can replace WIFI card for about $30 to 5GHz if needed B. HiRes Screen looks FANTASTIC. Some adaptations .1 System Settings >> Display : Scale on 2.0. .. But Nautilus seems to forget at times... strange, will investigate .2 >> Appearance: Launcher Icon size on 38 .2 Download Unity Tweak Tool with Software Centre: Appearance >> Fonts >> Window Title Font "Ubuntu 10" Cursor >> Use Larger Cursor (does not work for now...) .3 FireFox about:config >> layout.css.devPixelsPerPx = 2

The Rest? ... Well all seems to work. SO FAR SO GOOD

share|improve this answer

One more thing:

If you buy a yoga 2 pro, be aware of the display resolution of 3200x1800!

Gnome, KDE and Xfce are not yet ready for such crazy resolutions. The only workaround for me was to lower the resolution to full hd, so the text was still readable.

share|improve this answer
Screen res is not really a problem in KDE; try overrriding the font DPI and set to 180 and increasing icon sizes. Finally smooth fonts!! –  dhardy Nov 19 '13 at 15:18
Works rather well with Gnome too, nowadays. I guess two years ago it might've been worse. (Actually, it's better than Windows 8 regarding the resolution. The videocard can really handle this :) –  Lodewijk Feb 11 at 7:45

I'm running Ubuntu 13.10 on my Yoga 2 Pro. I think it's great! Battery life is 6+ hours. The yellow colors are a bit off, but it doesn't much bother me; the recent BIOS fix does not fix the color in Ubuntu. I have done a few things in addition to what's already been mentioned.

I've tweaked the touchpad settings, I created a file /etc/X11/Xsession.d/80xinput with the contents:

xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Profile" 2
xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 4
xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Adaptive Deceleration" 4
xinput set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Velocity Scaling" 8
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Finger" 35 45 0
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Coasting Speed" 5 15
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Tap Time" 120
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Tap Move" 300
xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Noise Cancellation" 20 20

Also I scaled the screen back a bit with the following:

xrandr --output eDP1 --scale 0.7x0.7

Ubuntu is happily booting in UEFI, and I can dual boot Windows 8.1 through Grub.

share|improve this answer
Did you leave the installed Windows 8 on it? Or did you reinstall Windows? And can you specifi, what you tweaked at your touchpad exactly? –  rubo77 Feb 27 '14 at 22:33
You can see all properties with xinput list-props "SynPS/2 Synaptics TouchPad" –  rubo77 Feb 28 '14 at 6:54
Some of these parameters are fully documented here: But I cannot find documentation for "Tap Time" –  rubo77 Feb 28 '14 at 7:04
How do you get 6 hours of battery life? I can get barely 2:30 hours! –  LeartS Jun 25 at 9:20

I tried 12.04.3 64bit but didn't work.

13.10 64 bit worked with the above described modifications.

Another fellow has a guide for the install:

In my case I want dual boot but the Ubuntu installer didn't detect the Windows installation so I choose "Something else" in the Ubuntu installer and created in my empty space (left space when I did my Win install) as ext4 and mount as / (root) and select this as spot to install boot.

Be sure you know what you do in the "Something else" Window of the ubuntu installer.

To modify /etc/default/grub after the install I select recovery mode in Grub and first run the fix grub error (to mount the disk in write mode) follow by the root console to edit the file via

sudo nano /etc/default/grub

for wifi follow the above tips.

For Hi DPI/ HiDPI / High resolution

I used GNOME 3.10 and it seem to handle the high dpi better than Unity: Install Gnome 3.10 in Ubuntu 13.10 without breaking Unity

For Firefox I played around with "about:config" and layout.css.devPixelsPerPx

share|improve this answer
What will the "about:config" and layout.css.devPixelsPerPx do? Maybe the Firefox addon NoSquint and Fix for zoomed default-font will fix your problems? –  rubo77 Jun 20 '14 at 15:53

Kubuntu on the Lenovo Yoga 2 Pro

(I've based these steps on the excellent answer given by rubo77 above as well as a few other sources)

Turn off fast boot and disable secure boot

  • Turn off the computer and start using the Novo button (small round button next to the power button)
  • Enter the BIOS configuration
  • Configuration->Enable Intel Virtualization
  • Security->disable Secure Boot.
  • Boot->disable Lenovo Fast Boot.


  • Turn off the computer and turn in back on using the novo button.
  • Select USB boot from the menu.
  • In the grub menu from the USB stick press e to edit the 'Install Ubuntu Server..' entry. Add 'acpi_backlight=vendor' before 'quiet'

Note: I use the Ubuntu Server installation to get full support for disk encryption, I then install the kubuntu-desktop package as well as various programs I like to use, to bring it up to a normal desktop. These instructions should work just as well with the normal Kubuntu installer if you don't want disk encryption (I've found the Kubuntu installer's disk encryption support very flakey).

Fix Wifi and other things (needs to be done after each kernel update)

  • Go to and click 'Download ZIP'
  • Assuming you downloaded the file to your Downloads/ folder run these commands to build and install the fixed ideapad-laptop module:

    cd ~/Downloads/
    cd yoga-laptop-master
    make ideapad-laptop
    sudo make ideapad-laptop-install

(Note if you followed the instructions by other users on this page: you should not blacklist the ideapad-laptop module anymore as this fixed version works)

Fix Sound

It seems Kmix defaults to controlling the HDMI audio device volume, not the inbuilt speakers/headphones device. To fix this, so you can use those very convenient volume buttons on the side of the laptop: Run Pulse Audio Volume Control (apt-get install pavucontrol) and under 'Output Devices' click 'Set as fallback' on 'Build in Audio Digital Stereo(HDMI)'.

Boot parameters

Without this grub boot parameter change I couldn't change the screen brightness (according to some sources video.use_native_backlight supersedes acpi_backlight=vendor). Edit /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="video.use_native_backlight=1 quiet splash"

Then run


Fix touchpad

Create a file /etc/modprobe.d/lenovo-yoga-two-pro.conf with the contents:

options psmouse proto=imps

Create a file /etc/X11/xorg.conf.d/50-synaptics.conf with the contents:

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
MatchDevicePath "/dev/input/event*"
Option "FingerLow"              "46"
Option "FingerHigh"             "46"
Option "SoftButtonAreas"        "60% 0 85% 0 40% 60% 85% 0" # Btn3 LRTB - Btn2 LRTB
Option "EmulateMidButtonTime"   "75"

Fix Everything too small in Hi Res

I don't think there's good support for 3200x1600 resolutions in current versions of X and KDE. I increased the DPI and reduced the resolution to 1920x1080:

Edit /etc/lightdm/lightdm.conf to add:

xserver-command=X -dpi 120

In KDE System Settings->Display set resolution to 1920x1080 (this change will persist between reboots)

In Firefox in about:config set layout.css.devPixelsPerPx set to 1.3 and install the add-on "Fix for zoomed default-font"

In Thunderbird just increase the text size with ctrl++

Fix Wifi Card instability

A fix for Ubuntu kernel bug was released in the package linux-image 3.13.0-36.63 (which is in the normal Ubuntu updates) in late September 2014. In my experience this has led to less Wifi instability, although it will occaisionally 'pause' for a few seconds, which is odd.

Even after installing the fixed ideapad-laptop module I found the wireless card (Intel Corporation Wireless 7260 (rev 6b)) was a bit unstable. Searching forums I found that the linux-firmware package has recently (August 2014) been updated with latest firmware files for the Intel wireless 7260. After installing this so far my wireless has worked problem free (fingers crossed :))

You need to get at least version 1.134, which is currently available for Utopic (14.10), but should work just fine installed on trusty (14.04). To get it browse and click "linux-firmware 1.134 in amd64 (Release)" (or whatever the newest is) and then on the next click "linux-firmware_1.134_all.deb" install the downloaded file: sudo dpkg -i linux-firmware_1.134_all.deb Reboot and that should be it

What There are still problems with

The touchscreen seems to only work as a simple mouse device - moving the cursor and clicking things works, but nothing like 2-finger scrolling or any gestures or swipes. If anyone knows how to improve this please post an answer.

Suspend/resume mostly works but I have seen some times where on resume the screen is blank grey. Ubuntu is working in the background, because I can ssh in to it and run 'sudo service lightdm restart' to fix it. I'm hoping the new ideapad-laptop module will fix this, I'm waiting to see if the problem re-occurs now I have it installed

Please upvote this post if you find it useful, I think my fixes improve on some of the other fixes suggested on this page and I hope this post is useful to people

share|improve this answer
great, the wireless seems to work better now (also with power save on) you can post this part about wifi as answer here too? Wireless card unstable on Lenovo Yoga 2 Pro –  rubo77 Sep 19 '14 at 18:56
Although I am not quite sure, if the latest linux-firmware did solve the wifi issue, I just had a new breakdown and had to reboot my laptop –  rubo77 Sep 19 '14 at 19:41
I've added a comment to that other question. The symptoms I got with the wifi was that every 30 mins or so it'd lose connection and NetworkManager would prompt for the password. Usually needed to disconnected, wait a minute or 2 and then reconnect before it'd work. After installing the new linux-firmware package this didn't happen. Note that I also have the fixed ideapad_laptop module (as detailed above). Possibly it's the combination of those 2 things that solved it (so far) for me. –  happyskeptic Sep 20 '14 at 17:33
Which comment in which other question? It definitely is no solution on its own, I had another fail just now. The symptom is, that the connection is lost, it tries to reconnect, but never stops, If I press "disable Wireless" in the nm-applet in the top, I cannot re-enable wireless ever after, because the wireless adapter is gone. Only a reboot helps. –  rubo77 Sep 20 '14 at 20:19
The question you linked to in the comment above: I just had the first wifi problem in the 2 days since I updated linux-firmware, so looks like it wasn't a full fix unfortunately. But I just had to wait a couple of minutes and then reconnect, no reboot needed. Not sure why your symptoms would be different. –  happyskeptic Sep 21 '14 at 12:04

I just bought one yesterday and can confirm that the hardware works flawlessly if you follow the suggestions on this page. Also Standby works out of the box.

BUT: as Michael Schär pointed out, missing High-DPI support in X11 is a big issue. I am actually returning the device because of this. there are two basic solutions but none of them really fully work:

1.) Use a lower Resolution and have the display interpolate everything. Works great, but makes everything blurry. If you just buy a Full-HD 13" Laptop rather than setting a low resolution on a Quad HD notebook, you end up having a cripser image. So why spend the extra $$ just to get a worse result?

2.) I usually run Xubuntu with xfce, but i have tried Unity and KDE as well and it is the same story with all of them: Increase Font DPI, use a High-DPI theme like TGC-Huge or Husky, increase Icon sizes, increase launch-bar size etc.: this gives you finally a readable and sharp appearance, but it totally messes up the appearance of different applications. One major issue is, that the default window size of a newly launched application is still the same as with the small icons and fonts, so in GIMP for example, you have to manually resize the window to see the full menu bar, also, the tool icons in GIMP are still tiny. Firefox needs an extra setting to scale up webpages, but that should work okay, Gnumeric shows tiny cells and they increase in size once you write something into them as the font is now huge compared to the cell size.. this messes up your sheets. the overall appearance just doesn't look right anymore and there is something wrong with almost every application.

So for me the decision is clear, i will return the laptop and get a cheaper Full-HD one which provides more desktop area to work with but is still readable and proportionally correct. I really hope that the missing High-DPI support will be added to our favourite Window Managers and the X-Servers soon.

share|improve this answer

I used PowerTOP to analyze and reduce battery power consumption on my Yoga 2 Pro. Here are the steps to automatically apply the optimizations.

Create script file /usr/share/ (don't forget to make it executable) with the following commands

#!/bin/sh -e

# PowerTOP tweaks

# VM writeback timeout
echo '1500' > '/proc/sys/vm/dirty_writeback_centisecs';

# Enable SATA link power Managmenet
for sata_host in `ls /sys/class/scsi_host/host*/link_power_management_policy`; do
    echo 'min_power' > $sata_host;

# NMI watchdog should be turned off
echo '0' > '/proc/sys/kernel/nmi_watchdog';

# Autosuspend for USB devices
for usb_dev in `ls /sys/bus/usb/devices/*/power/control`; do
    echo 'auto' > $usb_dev;

# Runtime PM for PCI Devices
for pci_dev in `ls /sys/bus/pci/devices/0000:00:*/power/control`; do
    echo 'auto' > $pci_dev;

# Using 'ondemand' cpufreq governor
/sbin/modprobe cpufreq_ondemand > /dev/null 2>&1
for cpu_core in `ls /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor`; do
    echo 'ondemand' > $cpu_core;


exit 0

In order to apply these optimizations every time the laptop switches to battery power create script file /usr/lib/pm-utils/power.d/z_powertop


# true == Battery
# false == AC

case "$1" in
    echo "Applying powertop optimizations"
    /usr/share/ || echo 'Failed!'

exit 0
share|improve this answer
great work, how can you get the script from power top suggestions ? –  Postadelmaga May 1 '14 at 21:58
@Postadelmaga here is good explanation: How do I make Powertop changes permanent –  Alexander Gololobov May 3 '14 at 19:59
BTW, kernel 3.14 has got Haswell CPU support in intel_pstate cpufreq driver. This dramatically improves idle power consumption. I'm getting 10+ hours battery lifetime with 20% brightness. –  Alexander Gololobov Jun 1 '14 at 18:02
@rubo77 I'd suggest the following: Install laptop-mode-tools first and then while running on battery look at PowerTop 'Tunables' tab to see if something in 'Bad' state. –  Alexander Gololobov Jun 20 '14 at 8:18
@JackSenechal intel_pstate is default since kernel 3.15 or so (currently I'm using 3.17.8). Also besides the optimizations mentioned above I have 1920x1080 resolution set and some kernel load params for i915: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor pcie_aspm=force acpi_osi='!Windows 2012' acpi=force acpi_enforce_resources=lax i915.lvds_downclock=1 i915.semaphores=1 i915.enable_psr=1 rootfstype=ext4" –  Alexander Gololobov Jan 25 at 9:41

Clickpad Disable While Typing

You cannot enable the "Disable While Typing" clickpad/touchpad feature in Ubnutu. This is the main reason why the we have so much trouble with the clickpad/touchpad although there are other aggravating issues. This is a bug in the Unity Settings Daemon with an easy fix which will significantly improve your quality of life.

Ubuntu uses syndaemon (not synclient) to set the “disable while typing” feature on the clickpad. The only function of syndaemon is “a program that monitors keyboard activity and disables the touchpad when the keyboard is being used”. This feature is broke due to and old bug since Ubuntu 12.04 that affects the clickpad/touchpad of all users whose laptop has this feature. There is a little bug in the unimportant syndaemon -t argument which crashes syndaemon. It can be fixed by a workaround of simply not using this argument. The unity-settings-daemon configuration uses this dysfunctional argument which then disables syndaemon. This bug fix is not implemented in the unity-settings-daemon apparently because of an oversight.

Syndaemon is not running when Ubuntu boots and if you simply go into the terminal and type the following “magic command” it will bring “disable while typing” back to life.

syndaemon -i 1 -K -R -d

It is configurable where “1” is the number of seconds it takes to enable the touchpad after typing has stopped. The optimum setting depends on your preferences which I think are related to your typing speed. I tried 2 and 4 seconds which I think were way too long and I like the 1 second the best. Someone said that you should make sure the “disable while typing” check box is unchecked in the mouse settings.

Go to “Startup Applications” and add a new preference that I called “disable clickpad while typing”. Then copy and paste the above command into the Command box and save it. Now it will start on boot. It is truly amazing what this command will do for you.

Bug report in Launchpad

AskUbuntu thread where I discovered this

Syndaemon Manual

share|improve this answer

PalmDetect Broke

The clickpad/touchpad should be centered on the keyboard (between G&H) but is placed in the center of the deck likely for design purposes. The clickpad is also very large and this all leads to the right edge of the clickpad pushing out a whole key to the right of the space bar. The clickpad is also flush and not recessed making it easier to touch accidentally. Because of all this, it is impossible to work without accidentally touching the clickpad with your right palm which moves the arrow / insert bar all over the place.

This makes the Synaptics PalmDetect function very important and synclient allows you to enable and configure it. However, PalmDetect is broke in the Yoga 2 Pro. There is a known issue for some clickpad/touchpads because of a kernel bug that causes the palm width to always be reported as 0. This is apparently what breaks palm detection in the Yoga 2 Pro. The synaptics package can be patched to use only Z for palm detection as a workaround. These patches are a bit beyond my capabilities so I haven't tried them.

Having said that, fixing the "disable while typing" and using synclient to FingerHigh/FingerLow and MinSpeed/MaxSpeed to appropriate values has made a tremendous difference in the clickpad/trackpad usability. The usability is now markedly improved and acceptable even without PalmDetect. Even so, if someone is able to figure out how to apply this patch to this laptop, please show us how to do it in simple steps. Hopefully, the kernel will be fixed in new releases.

I think it would be interesting to use synclient to inactivate the right hand centimeter of the touchpad/trackpad where most of the palm contact occurs. I did some few experiments with this but they were not successful. It would be helpful if someone who understands this better would come up with something to test.

Bug report with patch

Another similar patch

share|improve this answer

This is a great question, thank you everyone. @rubo77 has a super post. @ttomv echos my experience using a 14.10 install on my new Yoga Pro 2 purchased in 12/14.

WiFi not working

The stock kernel on 14.10 has been fixed, the WiFi problems are gone, and it now works out of the box. No more monkey business. We can now go back to focusing on tweaks.

Install Ubuntu to SD Card

I followed a different tack when I installed Ubuntu. The 256G SSD is smaller than I'm used to with a hard drive. To me, it is pretty small and I would have to share the 256G between two operating systems with a dual boot. I experimented with installing Ubuntu to an external data device. My intention was to use this external data card as an extension of the 256G SSD. 64G SDcards / USB sticks are now readily available and reachable in price. If I could get it to work it would increase my functional memory to 256 + 64 = 320G. In my mind, it was sort of like adding a 64G partition to the 256G SSD.

To install to an external device you need to choose "Install Ubuntu" and then "Something Else". This process is not unusually complex but be sure you research it well because there are some potential pit falls and the process is not particularly intuitive. You want to be sure to configure it so it installs to the external data device and also installs GRUB on the external device (not on the internal SSD). Set the mount point to "/".

So I happen to have a 64G SDcard and I put it into the card reader slot (USB 2.0) to see how well it would work. The SDcard in the reader worked just fine and Ubuntu came to life. Maybe through naivety, I did not touch the BIOS. I left Secure Boot and Fast Boot enabled. After installing Ubuntu on the jump drive, it showed up as UEFI.

However, it was slow when it was reading / writing to the SDcard but otherwise very fast (presumably when using RAM). So I figured I was onto something. I found that the right hand USB port is the USB 3.0 port and I researched fast USB 3.0 jump drives. I settled on the following tiny unit and ordered it waiting the obligatory week for it to arrive.

SanDisk Ultra Fit CZ43 64GB USB 3.0 Low-Profile Flash Drive 130 MB/s read

So... It works... I now have 320G of drive space... I don't know if it is as fast as the internal SSD but it is wicked fast. Booting it has some idiosyncrasies. When you boot into GRUB and let it sit on the default Ubuntu option, it locks on a dark backlit screen most of the time but occasionally works as it should and boots into Ubuntu. The work around is to go to the next line in GRUB "Advanced Options for Ubuntu", accept with enter, and then accept the top option to manually boot into Ubuntu.

I also find that it occasionally looses its theme (Radiance is my choice) and drops back to the default theme (Ambiance). This usually happens if I have been messing around in the BIOS and booting options and not when I have done a normal shut off and a normal boot. One or two reboots and it comes back.

I do not know if both of these issues are related to the jump drive install or also occur on a regular install. I'd be interested if anyone has any thoughts on these little idiosyncrasies and how to solve them. I have some other very useful tweaks but this post is already too long so I'll break them up by topic.

How to access SSD from Ubuntu

I also want to be able to access the SSD from Ubuntu. If Windows is hibernated you can't read the drive from Ubuntu. There is something called "Windows Fast Startup" that is a scaled down form of hibernate making for a quicker boot of Windows. However, it stores NTSF partition data in a file and locks up the SSD so Ubuntu can't access it. This is easy to fix by disabling it in Windows.

Control Panel > Hardware and Sound > Power Options > “choose what power button does” [System] > “change settings that are currently unavailable” > “Shut down settings” > uncheck “turn on fast startup”

This allows me to have a data directory on the SSD accessible from either the Ubuntu or the Windows 8 side. The price is that Windows boots a little more slowly. It's worth it to me.

share|improve this answer

Synclient Settings I Found Helpful

(the first two are extremely important)

Pressure Sensitivity Too Low

The pressure sensitivity is too low meaning that it responds to a touch with the slightest pressure. You need to make it so it requires more pressure to give a response so it is not always jumping with unintended brushes. I pushed it up as high as it would go before it started missing my normal finger touches. This is almost double the default which is set way too low.

Option "FingerLow" "45" 
Option "FingerHigh" "50"

Clickpad/Trackpad Too Fast

This setting has a bug. If you set these values using synclient you will find exactly what you set when you use synclient to list all the settings. However, if you set the same command using 50-synaptics.conf then synclient will always return a ratio with MinSpeed = 1 and MaxSpeed something more than that. The default is 1 and 1.75 but you don't know really what numbers created this ratio meaning you don't really know what is the default. Through trial and error I found a speed which worked well for me even in high resolution. When I use the configuration file to set new settings, synclient returns 1 and 2.25 but it seems the settings you set in 50-synaptics.conf are correctly rendered despite the values not being right. It's odd.

Option "MinSpeed" "0.4 "
Option "MaxSpeed" "0.9"

Disable Two Finger Right Click

Brushes of the clickpad/trackpad kept being intrepreted as two finger clicks and the right click dialog box was always popping up and slowing me down. Since I can right click at the bottom right, I found this more annoying than helpful. I disabled it and was much more happy.

Option "TapButton2" "0" 

Set 2 Finger Scrolling

I prefer 2 finger vertical and horizontal scrolling and not to have edge scrolling enabled at all. To accomplish this with the system defaults after the GNOME defaults were disabled (as in the above post}, I needed the following commands.

Option "VertEdgeScroll" "0" 
Option "HorizTwoFingerScroll" "1"

Below is my 50-synaptics.conf file with these changes. I hope my annotations are more understandable.

# /etc/X11/xorg.conf.d/50-synaptics.conf
# This section assigns the touchpad driver to all touchpads
Section "InputClass"
        Identifier "touchpad ignore duplicates"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"

# This section makes the touchpad ignore duplicates
# duplicates can lock up the touchpad
# ignore events from old driver
# this is a standard section in the conf file
Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"

# This section is for the actual configuration of the touchpad
Section "InputClass"
        Identifier "touchpad catchall"
        MatchIsTouchpad "on"
    Driver "synaptics"
    Option "FingerHigh" "50"
    Option "FingerLow" "45"
    Option "MinSpeed" "0.4"
    Option "MaxSpeed" "0.9"
    Option "VertEdgeScroll" "0"
    Option "HorizTwoFingerScroll" "1"
    Option "TapButton2" "0"

# This sections makes a bottom right corner right click
# and makes the right middle top area a right & middle buttons
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"

# End of configuration file
share|improve this answer

Synaptics Clickpad/Touchpad Configuration of Xorg Server Using Synclient

The arrow and cursor wanders and jumps unexpectedly making it nearly unusable out of the box. Besides the "Clickpad Disable While Typing" above, all the other settings are controlled by the Xorg server. It is my understanding that Xorg is replacing Xinput. Ideally we should be able to use apps like "Mouse and Touchpad" in system settings to make Xorg settings, but they are sub-functional with limited options and just not useful.

The method of configuration of synclient for the clickpad/touchpad is through the Xorg server configuration file called 50-synaptics.donf. This file lets you configure all the settings found in synclient. Don't forget that any given clickpad/touchpad may not have every function found in synclient so that is why some settings don't work. After installation of xf86-input-synaptics, a default Xorg configuration file is installed at this location.


Below are links to information on synclient settings.

You can over-ride the default settings with another 50-synaptics.conf file placed in a different location. It is common to copy the default file into this location and then modify the default file as a good starting point. This directory and file do not exist and you have to create the directory and past the default file there. This file is to be placed into this location.


There is another issue in that the GNOME settings daemon can over-ride both of these configuration files. You can disable the GNOME settings daemon for the mouse/touchpad properties with the dconf-editor. Go go to org > gnome > settings-daemon > plugins > mouse and dismiss the active option. Now the new 50-synaptics.conf is at the top level and should not be overridden.

The side effect is that you can no longer use "Mouse and Touchpad" settings under System > Preferences > Mouse but this is actually good because it is useless anyway. GNOME settings are user defined so if you have a second user you need to set this for that user as well.

When you create the new directories and create or modify the new file for 50-synaptics.conf, remember to open gedit as superuser in the terminal. Open Nautilus the same way.

sudo gedit
sudo nautilus

If you screw up making changes to 50-synaptics.conf you will find Ubuntu unforgiving and it will not boot. You can go into recovery mode and first do "network" to get into read/write and then use "root" which brings you to the terminal. You can use the mv Linux command to rename your file to something different (e.g. add bak at the end). Then your computer will reboot using the default configuration file. You will save the day and you can then use gedit and find out where you went wrong and fix your mistake. As I was experimenting this happened to me several times. You will have a lot more fun if you change the GRUB resolution before you start messing around so you can read what you type.

Synclient will return all the settings by simply typing synclient into the command line. I recommend you create a word processor document and copy theses settings. Do a copy of the installation default before you make any of changes. Make another copy after you have disabled the GNOME settings. Then, make a final copy after you have made your last settings.

It is usual to use synclient from the command line to experiment and test settings until you find what you think is best. Then finalized them into 50-synaptics.conf. Now you have the tools to configure your mouse.

share|improve this answer

Other Tricks

Screen Brightness

The screen defaults to full brightness which is unnecessary and is a battery killer. You can change the default brightness to a more appropriate 50%. Install xbacklight with Synaptic Package Manager which is a command line program to set the “back light” or screen brightness level. The following command line entry will set the screen to 50% brightness and if you put this command in the startup applications it will boot at 50% rather than 100%.

xbacklight -set 50

I found this here

Launcher Bar Reveal Sensitivity Too Low

Increasing the Unity Launcher Bar “reveal sensitivity” makes opening it by bumping the left side of the screen more usable. Move slider to about 50% (if the default line on the slider is 0%). I just discovered this setting by accident.

System Settings > Appearance > Behavior > Slider

Disable HotKey Mode

My preference is also for the “legacy” arrangement of the hotkeys where the default across the top row of keys is the function keys (F2 etc) and holding down the Fn key executes the Hotkey (such as screen brighness). This way you can get into the BIOS by booting and hitting F2 rather than Fn-F2 in the usual way. Disable the Hotkey Mode.

BIOS > Configuration > Hotkey Mode

Noted this from earlier post above

Reduce Screen Resolution

The default resolution is 3200 x 1800 (16:9). Set the screen resolution to the the next lowest setting with the same aspect ratio which is 1920 x 1080 (16:9) This gives you excellent screen sharpness and is is still amazingly high resolution. This is just the easiest way to deal with it. These settings hold through reboots. You can then continue to play with how to use the higher resolution if you want.

System Settings > Displays > Resolution > 1920 x 1080 (16:9)

Reduce GRUB Resolution

The GRUB resolution is so high that you can hardly read it. I got the idea to change it earlier in this thread but it turns out that GRUB does not support every resolution. After a bit of trial and error I found that 1280x1024 worked and was pleasantly sized to match the screen and seem like it matched the reduced resolution I chose. This is way more important than you might think.

How to Reduce Resolution

Post Above

share|improve this answer

Lenovo generally works fine, so go ahead and give it a try. I assume you're asking this before you buy it. If so, you'll probably be able to return it within a few weeks if it doesn't work.

So go ahead. The only thing you might have problems with is UEFI secure boot.

share|improve this answer
Thanks, yes, I'm just trying to prevent any headaches, because I'd like to order directly from the site. –  Dan G Oct 29 '13 at 16:34
I've got a Lenovo U310, and the Ubuntu 13.04 64bit iso didn't even need me to do anything with Secure Boot. You should be fine. –  Novine Oct 29 '13 at 16:35
If I helped, please choose my answer, or upvote, or something like that. –  Novine Oct 29 '13 at 16:36
Check the wifi card, SD card ports, non-integrated graphics cards etc for compatibility - THEY ARE AN UTTER PAIN OTHERWISE. Apart from that, my Lenovo G570 works just fine . –  Wilf Oct 29 '13 at 17:21
Lenovo tends to have a BIOS check that the wifi-card is from Lenovo, otherwise the machine won't boot - so "generally works fine" is a little broad. –  asjo Nov 29 '13 at 19:29

I'll add my experience as well. As this was the first time dual booting with UEFI, I wasn't as familiar with how to setup grub and such. My experience was Ubuntu "got it right" without too much trouble. I didn't change anything in the BIOS, I adjusted the drive size from Windows, then rebooted into the live USB, and when partitioning came up, selected "Something else" and created a /boot and a / partition. Thats it, I didn't mess with any existing partitions and the yoga worked great. Now I can use grub to select windows or (default) boot Ubuntu, but also, I can use the Novo button to select Windows if you so desire as well. Just thought I would put it out there for those who wondered how much work was involved in keeping Windows with Linux, answer: not much.

I'll just second the blacklisting of ideapad-laptop and the acpi_backlight=vendor boot option as good "basics."

Also, Unity is handling the resolution better than I even expected.How to find and change the screen DPI? is a great framework to find your preferred DPI settings. I had to play with it a little bit but found a good setting I can live with. By the way, I uses 277 and my DPI setting and text-scaling-factor as 1.6 but that is just my preference, I like small text!

share|improve this answer

protected by Community Dec 18 '13 at 6:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.