Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After hours of searching I just couldn't find a decent answer to the problem I am facing with my system, so I'm hoping one of you guys could help me out here.

I have an Asus N76VM laptop with nvidia GeForce 630M (drivers installed from nvidia, version 319), 8 GB ram, 2,5 GHz x4 intel i5, with Ubuntu 12.04 LTS installed.

Every once in a while and it seems completely random to me, the screen freezes. The solution to this problem was pressing ctrl+alt+f2 after freezing, followed by ctrl+alt+f7.

Now this solves the problem for me, but I am looking for a more permanent solution and I was hoping one of you guys could help me out with this.

Thanks in advance,

Nick

[EDIT]

Ok, so after searching a lot on the web for this issue, it seemed that the amount of people reporting this issue was almost as large as the different problems causing the freezing screen issue. I tried a lot of things to make it go away and ended up with a system that didn't function how it should any more.

I completely reinstalled Ubuntu 12.04 LTS but this time without the Nvidia drivers. As expected there were no screen freezes anymore and everyone was happy.

Now I want my Nvidia card to run sometimes when running programs that need more graphic processing power. I stumbled across Bumblebee and installed everything according to https://wiki.ubuntu.com/Bumblebee

After this I still received the following message when I type ¨optirun glxspheres¨ in the terminal:

[ 2019.967042] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 2019.967105] [ERROR]Aborting because fallback start is disabled.

For this problem there are just too many solutions, and n00by as I am, there is no way to get my head around this to solve it properly. I did install the latest kernel version as my last attempt to solve the problem.

[EDIT 3-11-2013]

Can someone please help me with just the nvidia/bumblebee issue? I'm searching the net and trying sollutions for the past 5 days now and itś starting to give me headaches.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I solved the issues I had as described in my question. Following the directions from the following link http://orkultus.wordpress.com/2013/04/20/how-to-nvidia-319-12-drivers-in-ubuntu-based-systems-with-bumblebee/ and after that configuring the /etc/bumblebee/bumblebee.conf file like so:

## Section with nvidia driver specific options, only parsed if Driver=nvidia

[driver-nvidia]

# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-331
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/nvidia:/usr/lib32/nvidia-331
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-331/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

After that i changed the /etc/bumblebee/xorg.conf.nvidia file

#"BusID PCI:01:00:0"

to

BusID "PCI:01:00:0"

After everything, how could something so small cost me so much time! I hope anyone learns from my experience :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.