Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu touch on my Galaxy Nexus, but i'm having trouble setting up a mobile broadband connection. My provider is Hollandsnieuwe, which is a virtual provider on the Dutch Vodafone network. My provider Hollandsnieuwe is not listed in /usr/share/mobile-broadband-provider-info/serviceproviders.xml, so i added the following entry:

<!-- Nehterlands-->
    <country code="nl">
        <provider>
                <name>hollandsnieuwe int.</name>
                <gsm>
                        <network-id mcc="204" mnc="04"/>
                        <apn value="data.dataxs.mobi">
                                <plan type="postpaid">
                                <usage type=ïnternet">
                        </apn>
                </gsm>
        </provider>
</country>

At the Hollandsnieuwe page i found the following settings, which were working when i ran Android. Name: hollandsnieuwe int.
APN: data.dataxs.mobi
Proxy: empty
Port: empty
Username: empty
Password: empty
MCC: 204
MNC: 04
Verification type: PAP
APN type: internet

Both cellular data and data roaming are enabled. Sometimes the 3G icon lights up for a couple of seconds and it goes away again. nmcli c tells me that the available gsm connection has never been used. But i can't start it with nmcli con up id connectionname Instead it returns:

WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/38: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


I tried a prepaid sim card from another provider, which gave me 3G access instantly.
Any help is appreciated.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.