Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use nvidia optimus gt540m graphics card. Today I upgraded to 13.10 successfully and installed Bumblebee but because of the problems about using external screen, I removed it using

sudo apt-get install ppa-purge

sudo ppa-purge ppa:bumblebee/stable

commands. After reboot, there was only black screen and a cursor after login even though login screen was still available. So, I installed nvidia-current but that didn't solve problem. After that, I reinstalled compiz, I activated unity-plugin from compiz-config settings manager.

Now, after restarting several times, unity may work. Even if it works, in spite of that multiple workspaces are allowed and shortcuts are set, I cannot switch workspaces using these shortcuts( e.g. ctrl+ alt + left). I want to set Unity back to it's initial settings ,the ones I used when I installed Ubuntu. I don't know if I installed drivers properly too and Unity doesn't seem to be working correctly.

Thanks in advance.

Edit: I managed to reset unity and shortcuts seem to be working now. But still, when I login, I usually end up with a black screen and a cursor. I open unity from ctrl+alt+F1, some parts remain missing like panel at the top. Its possible that I have a problem with drivers

share|improve this question
    
Go into a TTY and run export DISPLAY=:0 then unity --replace and software-properties-gtk. Press Ctrl+Alt+F7. You should see a window with information about your software sources. Switch the to "addition drivers" tab and see if there are any drivers. –  Seth Oct 29 '13 at 17:27

2 Answers 2

I found that I still had nvidia-304 installed. Not sure how it got there, but removing it fixed my problem with unity. Just make sure you have no nvidia packages installed and then reboot.

Having any nvidia drivers installed without having nvidia-prime or bumblebee will break unity.

sudo apt-get --purge remove nvidia-304 nvidia-common nvidia-settings-304

(Or a similar command for any different nvidia drivers you might have installed)

If you do want your nvidia card and dual screens, then install nvidia-prime.

share|improve this answer

If you want to reset Unity, you can follow the instructions here, but this may not be deep enough for you.

Have you tried installing another DE? Try

sudo apt-get install kubuntu-desktop

or similar.

share|improve this answer
    
Thanks for your help. I managed to reset unity and shortcuts seem to be working now. But still, when I login, I usually end up with a black screen and a cursor. I open unity from ctrl+alt+F1, some parts remain missing like panel at the top. Its possible that I have a problem with drivers –  functure Oct 29 '13 at 9:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.