Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.10 on my Windows 7 PC. Am a complete newbie to the linux system.

I first created a bootable Ubuntu USB to try out the OS without installing and the wireless worked fine with it after using the additional driver for Broadcom 802.11 Linux STA wireless driver from bcmwl-kernel-source.

However after installing Ubuntu from the bootable disk, I am no longer able to use this additional driver. Every time I select the additional driver and apply changes, nothing happens, no logs, errors, nothing :( and it switches back to the previous selection.

Please help and let me know how can I get the wireless driver to work on the installed Ubuntu.

EDIT : Please any information how to resolve this issue ?

share|improve this question
    
Did it ask you for your password? –  pratnala Oct 28 '13 at 17:31
    
yes it did but still it did not work eventually –  Aditya Oct 28 '13 at 17:34
    
Can you tell what does it say for the source? Is it something like Install from bcmwl-kernel-source? –  pratnala Oct 28 '13 at 18:14
    
No, it says the same thing as it does for the USB version,in Software & Updates > Additional Drivers > Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source –  Aditya Oct 29 '13 at 3:49

1 Answer 1

Open a terminal and type this:

sudo apt-get install bcmwl-kernel-source

This worked for me. Let me know if it works for you.

share|improve this answer
    
Will this work without an internet connection ? Right now, since the wireless is not working, I do not have any internet connection on the ubuntu system –  Aditya Oct 30 '13 at 8:11
    
Of course not! Were you trying previously as well without an internet connection? –  pratnala Oct 30 '13 at 8:28
    
No,no...I think I was not clear in my question...actually earlier when i booted ubuntu directly from USB (without installing), i was able to activate the additional driver and connect to the internet. Now, after installing it, I am not able to activate the same driver in the installed version (so no Internet)... that is the actual problem, I can still boot directly from the USB and get the driver to work. The question is why the bcmwl-kernel-source additional driver is not getting activated in the installed version... I hope I could clarify the exact questionnow –  Aditya Oct 30 '13 at 8:38
    
Connect to the internet via Ethernet and try installing it using the command I gave you –  pratnala Oct 30 '13 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.