Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What I have:

Sony Vaio laptop (SVE1512E6EW) with preinstalled Windows 8. I disabled Secure Boot some time ago in BIOS. I already had Ubuntu (previous version) installed on it, but removed it some time ago. After that, the default Windows boot menu is showing up every time I boot up computer, and the only entry is Windows 8.

What I did:

  • Burned Ubuntu 13.10 DVD
  • Restarted computer and booted from it
  • Chosen Install Ubuntu (not Try Ubuntu)
  • Created new ext4 partition from free space
  • Installed Ubuntu on it

What happened:

After the installation I restarted the computer. Windows default boot menu showed up (just as before) and the only entry was still Windows 8.

Update:

After running boot repair, I saw Ubuntu on boot list. I booted into Ubuntu and it worked fine, but after restart my computer was stuck at the black screen (with Vaio logo shown). So I decided to run boot repair again, but now when I try to boot into Ubuntu, I see the following error:

Windows failed to start. A recent hardware or software change might be the cause. 
To fix the problem:

 1. Insert your Windows Installation disc and restart your computer. (Windows came preinstalled).
 2. Choose your language settings, and then click "Next."
 3. Click "Repair your computer."

If you do not have this disc, contact your system administrator or computer manufacturer for assistance.  

File: EFI\ubuntu\grubx64.efi 
Status: 0xc000007b
Info: The application or operation system couldn't be loaded because a required file is missing or contains errors.

Here's the url that boot repair generated http://paste.ubuntu.com/6321056/

Update 2:

After I changed boot type in BIOS from UEFI to Legacy and the back from Legacy to UEFI Grub showed up for the first time. I could but to Ubuntu as well as into Windows 8. But after booting into Windows 8 and restarting computer, Grub didn't show up. I changed boot type to Legacy and back to UEFI again and Grub showed again. So basically, every time I change boot type to Legacy and back to UEFI it works fine, but when I boot into Windows 8 it changes something and prevents Grub from showing up (only Windows default boot menu is shown and the only option is Windows 8).

If you have any additional questions I will try to answer them as quickly as possible.

share|improve this question
    
Did Ubuntu have any problem with the installation? –  Braiam Oct 28 '13 at 22:09
    
Not that I am aware of –  kustrle Oct 28 '13 at 22:28
    
Is probably that you didn't installed the boot loader. Check this answer –  Braiam Oct 28 '13 at 22:35

3 Answers 3

1.Log in into your windows 8 os.Download and install EasyBCD from here.

2.Under linux section add a boot entry for your Ubuntu Partition.
And also add entry for your windows 8 partition.

3.reboot

Or

try boot-repair disk .

share|improve this answer
    
I added new entry with Grub 2 as type. After restart Ubuntu was on the boot list. But after choosing it, I immediatelly saw the following error: Windows failed to start. .... File: \NST\AutoNeoGrub0.mbr, Status: 0xc000007b, Info: The application or operation system couldn't be loaded because a required file is missing or contains errors. –  kustrle Oct 28 '13 at 18:45
    
make sure that you have select the correct partition where ubuntu is installed on easyBCD. –  Avinash Raj Nov 5 '13 at 10:53

Make sure you're booting from the right disk - the one with grub installed. If not, try using boot-repair in a live cd.

share|improve this answer

Installing ubuntu 12.10 alongside windows is very easy. First install any windows, then install ubuntu 12.10 alongside win8 or win7 and finally update to ubuntu 13.10.

share|improve this answer
1  
Why should we first install 12.10 then update to 13.10? Why not install simply 13.10? –  falconer Dec 22 '13 at 17:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.