Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug in my USB mobile broadband modem (ZTE MF-667), in the network manager instead of a mobile broadband connection, I get an Ethernet connection, called: Ethernet Network (ZTE WCDMA Technologies MSM), which of course doesn't work.

Here is my lsusb output and the relevant parts of dmesg output:

lsusb:  
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub  
Bus 001 Device 003: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth  
Bus 001 Device 004: ID 04f2:b1b9 Chicony Electronics Co., Ltd Asus Integrated Webcam  
Bus 001 Device 005: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader  
Bus 002 Device 004: ID 19d2:1405 ZTE WCDMA Technologies MSM   

dmesg:  
[  195.328467] usb 2-1.1: new high-speed USB device number 3 using ehci-pci  
[  195.423545] usb 2-1.1: New USB device found, idVendor=19d2, idProduct=1225  
[  195.423555] usb 2-1.1: New USB device strings: Mfr=3, Product=2, SerialNumber=4  
[  195.423561] usb 2-1.1: Product: ZTE WCDMA Technologies MSM  
[  195.423567] usb 2-1.1: Manufacturer: ZTE,Incorporated  
[  195.423572] usb 2-1.1: SerialNumber: P680A1ZTED000000  
[  195.426319] scsi7 : usb-storage 2-1.1:1.0  
[  196.425354] scsi 7:0:0:0: CD-ROM            CWID     USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2  
[  197.447919] usb 2-1.1: USB disconnect, device number 3  
[  197.457582] sr0: scsi3-mmc drive: 243x/186x xa/form2 cdda pop-up  
[  197.457594] cdrom: Uniform CD-ROM driver Revision: 3.20  
[  197.459058] sr 7:0:0:0: Attached scsi CD-ROM sr0  
[  197.459483] sr 7:0:0:0: Attached scsi generic sg2 type 5  
[  197.759186] usb 2-1.1: new high-speed USB device number 4 using ehci-pci  
[  197.854543] usb 2-1.1: New USB device found, idVendor=19d2, idProduct=1405  
[  197.854556] usb 2-1.1: New USB device strings: Mfr=4, Product=3, SerialNumber=5  
[  197.854564] usb 2-1.1: Product: ZTE WCDMA Technologies MSM  
[  197.854572] usb 2-1.1: Manufacturer: ZTE,Incorporated  
[  197.854579] usb 2-1.1: SerialNumber: P680A1ZTED010000  
[  197.957739] scsi8 : usb-storage 2-1.1:1.2  
[  198.076554] cdc_ether 2-1.1:1.0 eth1: register 'cdc_ether' at usb-0000:00:1d.0-1.1, CDC Ethernet Device, 00:a0:c6:00:00:00  
[  198.076583] usbcore: registered new interface driver cdc_ether  
[  198.955985] scsi 8:0:0:0: CD-ROM            CWID     USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2  
[  198.956797] scsi 8:0:0:1: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2  

I created the appropriate mobile broadband connection manually, but I cannot enable it in network manager, since the device is not recognized as mobile broadband.

Any tips how to make it work?

share|improve this question
    
First install ZTE linux modem drivers. –  Avinash Raj Nov 19 '13 at 12:26

2 Answers 2

I had the same problem with ubuntu 13.10 detecting ZTE MF667 as ethernet connection. The solution posted here didn't work for me, as wvdial was not able to detect it as a modem - which makes perfect sense, because it is an ethernet device. After trying different solutions, I stumbled upon this:

http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=3&t=1662

And finally I understood, that there is no problem with usb-modeswitch or anything!

You don't need to configure your connection in the ethernet settings at all. As I use it with an O2 sim card, I just connect to the ZTE ethernet connection, open my browser and go to "o2surf.stick" (this might be similar for your provider). I found this when I tried to run the setup.exe provided on the ZTE in Wine. There I can enter the PIN (can be disabled in the settings later) and connect to the mobile network. After that everything works fine :)

The interface provided by o2 reminds me of our wlan router config. You can see there your connection duration and the data volume used.

Sorry, if my English is somewhat awkward...

I hope, this might help some people.

share|improve this answer
    
On the Telstra 3G USB+WiFi version of this, the configuration settings page is at m.home –  tudor Apr 22 at 2:12

Yes! This is one of the problems I have been facing and here is a possible solution. Looking at your lsusb output, I find the following:

Bus 002 Device 004: ID 19d2:1405 ZTE WCDMA Technologies MSM 

This indicates that the Vendor ID is 0x19d2 and the Product ID is 0x1405. I would advise you the following steps:

(1) Create a bash script as follows. This bash script is to be run, everytime you would like to use your mobile modem CDMA connection. Let us suppose that the name of the bash script is `myModem.sh. Do this by typing:

sudo nano ~/myModem.sh 

Type in the following lines here:

#!/bin/bash
sudo /sbin/modprobe usbserial vendor=0x19d2 product=0x1405

Save your script and exit from nano. Type:

sudo chmod +x ~/myModem.sh

(2) Run the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install wvdial 
sudo apt-get install usb-modeswitch usb-modeswitch-data

(4) Type the following:

sudo nano /etc/udev/rules.d/90-zte.rules

and type in the following line (it is a single line and no carriage returns please):

SUBSYSTEM=="block",SUBSYSTEM=="scsi",ATTRS{model}=="USB Storage 1405",ACTION=="add",RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x1405"

Save the file and exit from nano.

(5) Now run your bash script from your home directory:

sudo ~/myModem.sh

(6) Now we have to configure wvdial.

sudo wvdialconf /etc/wvdial.conf

This will detect the modem and create a configuration file.

(7) Edit the configuration file to adjust the setting according to your country/service provider. Especially change the dialing phone number, username and password. Do this by typing

sudo nano /etc/wvdial.conf 

Remove the semicolons before the phone, username and password. The semicolons tell wvdial that these lines are commented. Save your file and exit from nano.

(8) Now create your connection. Make sure you check the Connect Automatically option.

I hope this will set your modem working.

share|improve this answer
    
I tried this method, but couldn't get my modem to work. At the 6th step, i got the following output: Scanning your serial ports for a modem. Modem Port Scan<*1>: S0 S1 S2 S3 S4 S5 S6 S7 Modem Port Scan<*1>: S8 S9 S10 S11 S12 S13 S14 S15 Modem Port Scan<*1>: S16 S17 S18 S19 S20 S21 S22 S23 Modem Port Scan<*1>: S24 S25 S26 S27 S28 S29 S30 S31 Sorry, no modem was detected! Is it in use by another program? Did you configure it properly with setserial? How should I configure it with setserial so the port scan finds the device? –  Bence Mihalka Nov 25 '13 at 12:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.