Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to bootstrap juju but this error shown below keep coming up.

 ERROR could not access file 'provider-state': Get http://X.X.X.138/MAAS/api/1.0/files/provider-state/: dial tcp X.X.X.138:80: no route to host

One more thing is my dashboard directory for maas is not 138, it's 140. How to change to 140? I'm stuck.

share|improve this question

2 Answers 2

Juju will use the url specified in your environments.yaml file under a provider of type maas.

It should look something like this:

maas:
  type: maas
  # Change this to where your MAAS server lives.  It must specify the base path.
  maas-server: 'http://192.168.1.140/MAAS/'

Note, there can be some differences based on the version of Juju you're using, so if you could edit your post to state the version of Juju, it would make it easier for us to answer definitively.

share|improve this answer

I came across the same errror, and yes indeed it was a typo in the mass-server URL at the ~/.juju/environments.yaml

Yet after fixing it and bootstrapping again, same error appeared.

The I removed the file ~/.juju/environments/maas.jenv and tried again. works like charm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.