Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, we´re setting up an UBUNTU 12.04 lts server at my office, and had it nice and running with our static IP. However, when we tried changing the IP for another one (just changing the /etc/network/interfaces file), we lost internet connection. When we tried to return to the previous IP, the problem persisted.

Here's the mentioned file:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 195.0.64.13 #this one is the ip that worked before
netmask 255.255.255.0
network 195.0.64.0
broadcast 195.0.64.255
gateway 195.0.64.1
dns-nameservers 200.54.144.227 200.54.0.10

if I do an ifconfig, eth0 looks fine, but RX packets are all in 0, same as TX packets

The output of route -n:

Destination  Gateway      Genmask     Flags Metrics Ref Use Iface
0.0.0.0     195.0.64.1    0.0.0.0       UG   100     0   0   eth0
195.0.64.0  0.0.0.0     255.255.255.0   U     0      0   0   eth0

Any help on this matter would be most appreciate.

Also, something else, this happened once befere, when we were just setting the server up, and even after a format and fresh install the conection was down. We installed a windows version to see if it was a configuration or a hardware problem. Windows could connect to internet. Then, when we reinstalled Ubuntu, the problem was solved (until we had to change the ip once again...)

share|improve this question
    
Can you ping the gateway? ping -c3 195.0.64.1 –  chili555 Oct 28 '13 at 13:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.