Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to upgrade from 13.04 to 13.10, but some broken packages are preventing upgrade success:

grep Broken /var/log/dist-upgrade/apt.log output:

Broken libwayland-client0:amd64 Conflicts on libwayland0 [ amd64 ] < 1.0.5-0ubuntu1 > ( libs ) (< 1.1.0)
Broken libunity9:amd64 Breaks on unity-common [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 > ( gnome ) (< 7.1.2)
Broken cups-filters:amd64 Conflicts on ghostscript-cups [ amd64 ] < 9.07~dfsg2-0ubuntu3.1 > ( text )
Broken libpam-systemd:amd64 Conflicts on libpam-xdg-support [ amd64 ] < 0.2-0ubuntu2 > ( admin )
Broken libharfbuzz0a:amd64 Breaks on libharfbuzz0 [ amd64 ] < 0.9.13-1 > ( libs )
Broken libharfbuzz0a:amd64 Breaks on libharfbuzz0 [ i386 ] < 0.9.13-1 > ( libs )
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ amd64 ] < 6.90.2daily13.04.05-0ubuntu1 > ( gnome ) (< 7.0.7)
Broken libunity-scopes-json-def-desktop:amd64 Conflicts on libunity-common [ i386 ] < none > ( none ) (< 7.0.7)
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken libaccount-plugin-generic-oauth:amd64 Breaks on account-plugin-generic-oauth [ amd64 ] < 0.10bzr13.03.26-0ubuntu1.1 > ( gnome ) (< 0.10bzr13.04.30)
Broken libmutter0b:amd64 Breaks on libmutter0a [ amd64 ] < 3.6.3-0ubuntu2 > ( libs )
Broken python3-aptdaemon.pkcompat:amd64 Breaks on libpackagekit-glib2-14 [ amd64 ] < 0.7.6-3ubuntu1 > ( libs ) (<= 0.7.6-4)
Broken apache2:amd64 Conflicts on apache2.2-common [ amd64 ] < 2.2.22-6ubuntu5.1 > ( httpd )
Broken chromium-codecs-ffmpeg-extra:amd64 Conflicts on chromium-codecs-ffmpeg [ amd64 ] < 28.0.1500.71-0ubuntu1.13.04.1 -> 29.0.1547.65-0ubuntu2 > ( universe/web )
Broken unity-scope-home:amd64 Conflicts on unity-lens-shopping [ amd64 ] < 6.8.0daily13.03.04-0ubuntu1 > ( gnome )
Broken libsnmp30:amd64 Breaks on libsnmp15 [ amd64 ] < 5.4.3~dfsg-2.7ubuntu1 > ( libs )
Broken apache2.2-bin:amd64 Breaks on gnome-user-share [ amd64 ] < 3.0.4-0ubuntu1 > ( gnome ) (< 3.8.0-2~)
Broken libgjs0d:amd64 Conflicts on libgjs0c [ amd64 ] < 1.34.0-0ubuntu1 > ( libs )
Broken unity-gtk2-module:amd64 Conflicts on appmenu-gtk [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken lib32asound2:amd64 Depends on libasound2 [ amd64 ] < 1.0.25-4ubuntu3.1 -> 1.0.27.2-1ubuntu6 > ( libs ) (= 1.0.25-4ubuntu3.1)
Broken unity-gtk3-module:amd64 Conflicts on appmenu-gtk3 [ amd64 ] < 12.10.3daily13.04.03-0ubuntu1 > ( libs )
Broken activity-log-manager:amd64 Conflicts on activity-log-manager-common [ amd64 ] < 0.9.4-0ubuntu6.2 > ( utils )
Broken libgtksourceview-3.0-0:amd64 Depends on libgtksourceview-3.0-common [ amd64 ] < 3.6.3-0ubuntu1 -> 3.8.2-0ubuntu1 > ( libs ) (< 3.7)
Broken icaclient:amd64 Depends on lib32asound2 [ amd64 ] < 1.0.25-4ubuntu3.1 > ( libs )
Broken libunity-core-6.0-5:amd64 Depends on unity-services [ amd64 ] < 7.0.0daily13.06.19~13.04-0ubuntu1 -> 7.1.2+13.10.20131014.1-0ubuntu1 > ( gnome ) (= 7.0.0daily13.06.19~13.04-0ubuntu1)
Broken libbamf3-1:amd64 Depends on bamfdaemon [ amd64 ] < 0.4.0daily13.06.19~13.04-0ubuntu1 -> 0.5.1+13.10.20131011-0ubuntu1 > ( libs ) (= 0.4.0daily13.06.19~13.04-0ubuntu1)
Broken apache2-bin:amd64 Conflicts on apache2.2-bin [ amd64 ] < 2.2.22-6ubuntu5.1 -> 2.4.6-2ubuntu2 > ( httpd ) (< 2.3~)

Output for cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://de.archive.ubuntu.com/ubuntu/ raring main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ raring-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ raring universe
deb http://de.archive.ubuntu.com/ubuntu/ raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://de.archive.ubuntu.com/ubuntu/ raring multiverse
deb http://de.archive.ubuntu.com/ubuntu/ raring-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

deb http://security.ubuntu.com/ubuntu raring-security main restricted
deb http://security.ubuntu.com/ubuntu raring-security universe
deb http://security.ubuntu.com/ubuntu raring-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu raring partner
# deb-src http://archive.canonical.com/ubuntu raring partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu raring main
# deb-src http://extras.ubuntu.com/ubuntu raring main
# deb http://linux.dropbox.com/ubuntu precise main

output for sudo dpkg -l | grep -e "^iU" -e "^rc":

rc  ibm-lotus-cae                             8.5.2-20100805.0821                        i386         IBM Lotus Composite Application Editor
rc  ibm-lotus-cae-nl1                         8.5.2-20100805.0821                        i386         IBM Lotus CAE NL1
rc  ibm-lotus-feedreader                      8.5.2-20100805.0821                        i386         Feeds for IBM Lotus Notes 8.5.2
rc  ibm-lotus-feedreader-nl1                  8.5.2-20100805.0821                        i386         IBM Lotus Feed Reader NL1
rc  ibm-lotus-notes                           8.5.2-20100805.0821                        i386         IBM Lotus Notes
rc  ibm-lotus-notes-core-de                   8.5.2-20100805.0821                        i386         IBM Lotus Notes Native German (de)
rc  ibm-lotus-notes-nl1                       8.5.2-20100805.0821                        i386         IBM Lotus Notes Java NL1
rc  ibm-lotus-sametime                        8.5.2-20100805.0821                        i386         IBM Lotus Sametime
rc  ibm-lotus-symphony                        8.5.2-20100805.0821                        i386         IBM Lotus Symphony
rc  ibm-lotus-symphony-nl1                    8.5.2-20100805.0821                        i386         IBM Lotus Symphony NL1
rc  libapache2-mod-php5filter                 5.4.9-4ubuntu2.2                           amd64        server-side, HTML-embedded scripting language (apache 2 filter module)
rc  libavcodec53:amd64                        6:0.8.6-1ubuntu2                           amd64        Libav codec library
rc  libavutil51:amd64                         6:0.8.6-1ubuntu2                           amd64        Libav utility library
rc  libmotif4:amd64                           2.3.3-7ubuntu1                             amd64        Open Motif - shared libraries
rc  linux-image-3.8.0-25-generic              3.8.0-25.37                                amd64        Linux kernel image for version 3.8.0 on 64 bit x86 SMP
rc  linux-image-extra-3.8.0-25-generic        3.8.0-25.37                                amd64        Linux kernel image for version 3.8.0 on 64 bit x86 SMP
share|improve this question
1  
Can you add the output of sudo apt-get check? Also, cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list. –  Braiam Oct 28 '13 at 9:43
    
There is none for apt-get check. Adding the others now. Reading package lists... Done Building dependency tree Reading state information... Done –  Andreas Hartmann Oct 28 '13 at 9:45
    
Please, edit your question and add the information, do not use comments. –  Braiam Oct 28 '13 at 9:46
1  
What is the output of sudo dpkg -l | grep -e "^iU" -e "^rc" Edit your question and post the output. –  Saurav Kumar Oct 28 '13 at 9:52
    
I was expecting broken packages but you've residual packages Try to remove first all residual packages and then try to upgrade your system once. Use this link to remove all residual packages and this link to upgrade your system safely. –  Saurav Kumar Oct 28 '13 at 10:00

3 Answers 3

sudo apt-get -f install

See if the above command works

share|improve this answer
    
I already tried: Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. –  Andreas Hartmann Oct 28 '13 at 9:04
    
bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/… It seems that this has been reported as a bug. –  user206859 Oct 28 '13 at 9:10
    
This is exactly my problem. So it is a known bug and I will have to wait for a fix? –  Andreas Hartmann Oct 28 '13 at 9:11
1  
bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/… The last comment in the above link provides a possible solution. The answer Brian Murray gives is "Reviewing the files from your upgrade attempt you seem to have enabled the xorg-edgers-ppa. This will prevent the upgrade as that PPA contains different versions of packages essential to Ubuntu. The page, launchpad.net/~xorg-edgers/+archive/ppa, contains details on to how to revert to the official Xorg packages." –  user206859 Oct 28 '13 at 9:15
    
Thanks, the following is suggested on that site: sudo ppa-purge xorg-edgers However that ppa can not be found on my system –  Andreas Hartmann Oct 28 '13 at 9:27

you can upgrade your os again so that new packages will be installed and this broken packages will be fixed.

share|improve this answer
1  
Upgrading fails, which is my issue: bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/… –  Andreas Hartmann Oct 28 '13 at 9:12
up vote 0 down vote accepted

I violently force the upgrade, by editing my sources.list to only include the 13.10 update sources. Then just apt-get update, upgrade, dist-upgrade, autoremove, autoclean. Surprisingly, later the upgrade to trusty just worked with do-release-upgrade.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.