Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to setup CNTLM on an Ubuntu VM and keep hitting a brick wall with the above error message.

Here are the steps I've taken:

Install CNTLM

$ ls
cntlm_0.92.3-0ubuntu0.1_i386.deb cntlm.conf
$ sudo dpkg -i cntlm_0.92.3-0ubuntu0.1_i386.deb
Selecting previously unselected package cntlm.
(Reading database ... 29361 files and directories currently installed.)
Unpacking cntlm (from cntlm_0.92.3-0ubuntu0.1_i386.deb) ...
Setting up cntlm (0.92.3-0ubuntu0.1) ...
Adding system user `cntlm' (UID 106) ...
Adding new user `cntlm' (UID 106) with group `nogroup' ...
Creating home directory `/var/run/cntlm' ...
Starting CNTLM Authentication Proxy: cntlm.
Processing triggers for ureadahead ...
Processing triggers for man-db ...

Copy my cntlm.conf to the right place

$ cat cntlm.conf
Username        [redacted]
Domain          AUS
Workstation     WS0585249
PassLM          [redacted]
PassNT          [redacted]
PassNTLMv2      [redacted]
Proxy           [redacted]:8080
NoProxy         localhost, 127.0.0.*, 10.*, 192.168.*
Listen          3125
$ sudo cp cntlm.conf /etc/cntlm.conf

Restart CNTLM

$ sudo invoke-rc.d cntlm restart
Stopping CNTLM Authentication Proxy: cntlm.
Starting CNTLM Authentication Proxy: failed!

Restarting service failed, attempt to start manually?

$ sudo cntlm -vc /etc/cntlm.conf
section: global, Username = '[redacted]'
section: global, Domain = 'AUS'
section: global, Workstation = 'WS0585249'
section: global, PassLM = '[redacted]'
section: global, PassNT = '[redacted]'
section: global, PassNTLMv2 = '[redacted]'
section: global, Proxy = '[redacted]:8080'
section: global, NoProxy = 'localhost, 127.0.0.*, 10.*, 192.168.*'
Adding no-proxy for: 'localhost'
Adding no-proxy for: '127.0.0.*'
Adding no-proxy for: '10.*'
Adding no-proxy for: '192.168.*'
cntlm: No proxy service ports were successfully opened.
Exitting with error. Check daemon logs or run with -v.

The VM is a fresh copy of precise32 being run via Vagrant and VirtualBox on a Windows 7 host.

I've also tried changing the port CNTLM listens on and a previous version of CNTLM (0.91~rc6). I haven't managed to turn up much information on the specific error message and have just about exhausted my skill set here.

The primary objective here is simply to authenticate against an NTLM corporate proxy so things like apt-get and wget are usable. I'm open to other solutions which would achieve this aim.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This looks to be a bug in CNTLM. The error was eventually solved by simply adding a blank line at the end of the config file.

Cntlm appears to ignore the last line of the config file regardless of its content, so simply adding a blank line at the end works around this bug.

I've filed a bug report here: https://sourceforge.net/p/cntlm/bugs/59/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.