Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using xubuntu and recently I encounter this problem:
When the computer started up, a main window Files Manager appeared automatically and I don't why this happens. There are bunch of startup applications and I can't locate which one of them causes this.

Is there any solution? Thanks!

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

What you're experiencing is XFCE's automatic session saving. It will attempt to restore the session you had before logging out.

You can nuke the cached sessions with a quick rm -rf ~/.cache/sessions/* but for long-term disablement, there is another answer on the site that involves forcibly disabling it.

Chances are now that you know what to expect (if you leave windows open before you log out), you won't be so surprised and confused.

share|improve this answer
    
I feel sooo happy to learn this interesting feature in xfce now, no more confused! Many thanks! –  AmareKnight Oct 28 '13 at 6:14
add comment

In addition to Oli's answer, you can disable this feature once by using the following steps to shutdown instead of the normal shutdown menu entry:

  1. Click the "Logout" menu entry.
  2. Uncheck the "Save session for future logins" checkbox near the bottom.
  3. Click the type of operation (shutdown/reboot) which you'd like to do.

If you want this to be unchecked by default, use the following steps:

  1. Open XFCE's Setting Manager.
  2. Navigate to "Session and Startup", the 'General' tab.
  3. Uncheck “Automatically save session on logout”.

Reference:

  1. Some of my applications are always started when I login
share|improve this answer
    
Thanks for the reference! I feel very lucky to get help from someone who know exactly what I'm experiencing. –  AmareKnight Oct 28 '13 at 6:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.