Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have noticed, even going back to Ubuntu 11.xx releases the screen for some ungodly reason dims itself while a video is playing. Iv'e even observed the thing go into sleep mode with the audio still going till it shut itself off. Here we are at 13.10 and this is STILL the case >:{ (same with Mint15 and Fedora)

It doesn't matter if I'm using VLC or watching youtube on Firefox or Chrome. The darn computer for some reason thinks nothing is going on!

I could go into how this never happened on Windows nor Mac, but I'll just say this; Why isn't this something built in by DEFAULT!!!

Has anyone a WORKING(ie the famous one I've run into don't work/refer to sites or scripts that no longer exist) system level tweak/script/fix for this nonsense?!(before I throw my already dying laptop out the window)

share|improve this question

3 Answers 3

I suggest using a program called Caffeine.

Once you have installed Caffeine, and disabled the screensaver, any videos that you watch will not be interrupted by the power management.

Caffeine

I have this on my system and it works perfectly.

Caffeine Preferences

Disabled Screensaver

share|improve this answer
    
Does it really prevents the screen from going black while reading a video on Youtube ? What do you mean by ""screensaver" ? There is no such thing in recent Ubuntu releases. Maybe Brightness & lock ? Because disabling the screensaver in the caffeine menu simply disables it, not only when you play videos. –  Antoine Lecaille Nov 2 '13 at 8:48
    
It does stop the screen from going into Power Saving Mode [Going Black]. –  scouser73 Nov 2 '13 at 9:42
    
Not on my system. Screen goes black (as set in Brightness & Lock ) even when Activate for Flash video is checked. –  Antoine Lecaille Nov 2 '13 at 10:50
    
Make sure that Turn Screen Off When Inactive For: is set to Never. –  scouser73 Nov 2 '13 at 11:56
    
Then what is the point of Caffeine if I disable the screensaver ? –  Antoine Lecaille Nov 2 '13 at 12:26

There is an app called caffeine that solves this for you:

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine

Caffeine's launchpad page

share|improve this answer

After not finding any good solution (It should be Firefox informing Gnome not to darken the screen, as it happens with VLC), I've solved the problem the other way around:

  1. Disable screen from going black: Settings > Brightness & Lock > Turn screen off when inactive for: Never
  2. Add a keyboard shortcut that darkens the screen: Settings > Keyboard > Shortcuts Tab > Custom Shortcuts > new (+):

Name: screensaver (or whatever you want) Command: gnome-screensaver-command -a

Click "Accept" and set the key combination you like to activate it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.