Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Wifi connection to my university wifi, which is a PEAP/WPA2/mschapv2 network with no offered certificate, drops constantly. It has a weird pattern where earlier in the day it drops fairly rarely(~every 30 minutes), but as the time spent on the device increases, it drops more and more until times when drops occur every 2-3 minutes, and eventually it becomes basically impossible to connect, at which point I try turning Networking off/on, which sometimes works, or deleting and recreating the saved network, which often works, but both of these fixes still just give me a few more minutes. Rebooting tends to "reset" the issue back to a point where it doesn't drop as often, but again it decays with time.

I'm currently on Elementary (Ubuntu 12.04), but I've run sudo apt-get upgrade and dist-upgrade, so I imagine that everything is up to date. Additionally, I experienced the exact same problem a few weeks ago on 13.04.

Fixes I've already tried:

(1) Setting IPv6 connection to "ignore" in the network manager dialog box. Doesn't seem to do anything.

(2) Setting system-ca-cert=false in /etc/NetworkManager/system-connections. The line seems to always be removed and I've never seen system-ca-cert=true in there.

Here's my systems-connection file for reference:

[ipv6]
method=ignore

[connection]
id=ssid_name
uuid=xxx-xxx-xxx
type=802-11-wireless
timestamp=1382910760

[802-11-wireless-security]
key-mgmt=wpa-eap

[802-11-wireless]
ssid=ssid_name
mode=infrastructure
mac-address=00:23:15:AE:F4:F0
security=802-11-wireless-security

[802-1x]
eap=peap;
identity=username
phase2-auth=mschapv2
password=mypassword

[ipv4]
method=auto

and here's some info about my wireless card:

   description: Wireless interface
   product: Centrino Advanced-N + WiMAX 6250 [Kilmer Peak]
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlan0
   version: 5f
   serial: 00:23:15:ae:f4:f0
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-54-generic firmware=41.28.5.1 build 33926 ip=10.164.93.55 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn

Any way I could fix this? It's killing me and basically making using ubuntu impossible at my university after being a dedicated user for 6 years.

share|improve this question
    
I was having similar issues with my onboard WiFi (RealTek) and switched to Intel Advanced-N 6205 [Taylor Peak] (rev 34)... this solved my problem... however, I did take an interim hop with a cheap USB adapter, which you may want to try.... this works well with Ubuntu: amazon.com/Panda-150Mbps-Wireless-N-2-4GHz-Adapter/dp/… –  Kendor Oct 27 '13 at 22:16
    
Please try: sudo modprobe -r iwlwifi && sudo modprobe iwlwifi 11n_disable=1. Any change? If so, we'll make it persistent. –  chili555 Oct 27 '13 at 22:47
    
Unfortunately, after about ~5 hours after running your suggestion and not restarting or anything, the wifi has gone to dropping about every 5 minutes or so again. –  Turner Oct 28 '13 at 3:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.