Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to put Ubuntu on my phone. When I run the command phablet-flash ubuntu-system --channel devel --no-backup in the terminal it says:

INFO:phablet-flash:Device detected as toroplus
ERROR:phablet-flash:Unsupported device, autodetect fails device

What do I do?

share|improve this question
    
What kinda of phone and what version on Ubuntu? –  hydroxide Oct 27 '13 at 17:40
    
@hydroxide obviously this. –  LiveWireBT Oct 28 '13 at 6:04
add comment

1 Answer 1

The toroplus appears to be one of the two CDMA variants of the Galaxy Nexus. The ubuntu-system images currently only support the GSM variant of that handset (maguro), which explains the error.

It looks like someone in the community ported one of the early phone images to toroplus, but it doesn't look like it's been updated in about 8 months:

https://wiki.ubuntu.com/Touch/Devices/toroplus

It also says that the actual phone functionality doesn't work on that image (an area where the CDMA version differs from the original GSM one). More information can be found in the forum thread on XDA Developers:

http://forum.xda-developers.com/showthread.php?t=2159832

share|improve this answer
    
Unfortunately the link for the device specific zip is down, so that answer is not usable at the moment –  sbergeron Jul 7 at 20:01
    
I'm not sure whether it is worth trying to get it running on this hardware any more anyway. The GSM Galaxy Nexus is no longer supported for development (it's GPU is significantly less capable than the others). –  James Henstridge Jul 7 at 23:47
    
an old phone is still worth it, when the latest and greatest can't run great on it I thought that was exactly what ubuntu was for, for machines that either you like ubuntu on or that don't run the latest software. Just dropping support for a device that still functions seems foolhardy and somewhat against the main goal of ubuntu, an os for every computer –  sbergeron Jul 8 at 0:19
    
The current set of supported devices represent what we have been using for development. The end goal is to make phones with Ubuntu preinstalled available to end users, rather than having them buy Android phones and reflash them. Here's the message about EOL'ing the Galaxy Nexus: lists.launchpad.net/ubuntu-phone/msg05889.html –  James Henstridge Jul 8 at 2:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.