Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh Dual Boot system (UEFI, Windows 8.1 and Ubuntu 13.04). Ubuntu boots fine (from a SSD on SATA Port 3). However, once I connect a hard disk (to SATA Port 1), Ubuntu will boot only once and then will lockup after Grub (Blank screen, no messages) after further reboots. In the first (working) boot, the hard disk is recognized and working just fine (it is formatted as NTFS). Windows boots without problems with the additional hard disk attached and reports no problems whatsoever. The only way I can get Ubuntu to boot again after the first connect is to disable the SATA port in the BIOS.

To summarize:

  • Harddrive physically detached: Both Ubuntu and Windows boot fine
  • Harddrive then connected: Both Ubuntu and Windows boot fine
  • Reboot, Hardrive connected: Ubuntu does not boot, Windows boots
  • Disable SATA1-Port: Ubuntu boots again
  • Enable SATA1- Port: Ubuntu won't boot

It is very strange. While I cannot be absolutly positive that the hard disk is ok, i am pretty sure.

Is there any chance that I can get some error log out of Ubuntu for the last boot attempt. Perhaps someone can give me a hint on how to debug this issue?

Thanks!

share|improve this question
add comment

2 Answers 2

Recently I got a problem that may give you some hint.
I bought a Vostro 3550 notebook which came with only a 1TB HDD. I bought a 120Gb SSD and a caddy to replace the notebook's DVD writer. First I tried to put the SSD as a secondary device, I mean, just replaced the DVD driver. I created a 1TB partion on the first device (HDD) for /home and 2 partitions on the secondary device (SSD) for / and swap. Instalation finished ok, but as I restarted the computer, it just won't start. Not even grub.
Though it maybe some instalation error, tried again, same thing.
Then I phisically changed the places of HDD and SSD making SSD primary with the same partitions in it, and all worked like a charm.
Hope it helps.

share|improve this answer
add comment

i do not have a solution. but in fact i'm having sort off the same issue.

i just bought a new WD 2TB drive. same make and model as a drive i already have. i boot from an 64Gb SSD. but when i boot, after the bios the screen goes blank with just a blinking underscore. (the moment GRUB shout load so to speak).

when i (on power off) unplug the drive from the power and boot the pc it works fine. then i plug in the power to the drive at the moment i see the ubuntu splash screen (hotplug). and everything works like a charm.

with a lack of comment points: Thanks for the suggestion. but in my case the new 2Tb drive replaced 2 separate fysical drives (both 500Gb). and the new drive was split into 3 virtual drives. also in FSTAb i'm using the drives UUID in stead of the /dev allocation. also i should mention that it worked great for several weeks. and than started to fail.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.