Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Command apt-cache show postgresql will listed this information in my machine (Saucy Salamander 13.10):

$ apt-cache show postgresql
Package: postgresql
Priority: optional
Section: database
Installed-Size: 69
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian PostgreSQL Maintainers <pkg-postgresql-public@lists.alioth.debian.org>
Architecture: all
Source: postgresql-common (148)
Version: 9.3+146really9.1+148
Depends: postgresql-9.1

It says postgresql package version 9.3+146really9.1+148. What the meaning of really here?

  • is this version 9.1 but listed as 9.3?
  • or this is version 9.1 with patch back-ported from 9.3?
  • or something else?
share|improve this question

1 Answer 1

up vote 10 down vote accepted

It's actually 9.1. Saucy seems to be pulling postgresql* packages from Debian's unstable dist, where because of some version dependencies they had to make the 9.1 branch look like 9.3 to the package manager until 9.3 graduates from their experimental to their unstable distro.

See here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707675

Especially the changelog bit reading:

   * debian/supported-versions: Don't explicitly support 9.3 for
     testing/unstable yet, it is still in experimental. (Closes: #707675)
   * debian/rules: Hack the version number of the metapackages to be
     9.3+142really9.1-..., so that they are bigger than the previous botched
     versions. This needs to stay until 9.3 actually goes into unstable.
share|improve this answer
    
one example of dependency hell... :D thanks for tracking back into exact bug information. –  flamemyst Nov 2 '13 at 6:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.