Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu 10.04 I had some flickering issues, so I tried upgrading drivers and such, then I installed the fglrx driver and the flickering have gone away but when trying to access the TTY screens from 1-6 the screen goes blank. I'm able to get back in to gnome on tty7.

any one have a suggestion on what to try here?


Dennis

the output is:

glennwiz@Linux-laptop:~$ sudo cat /dev/vcs1

Ubuntu 10.04.1 LTS Linux-laptop tty1

Linux-laptop login:    

Nerdfest im using radeon x1300

lspci output
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc M52 [Mobility Radeon X1300]
02:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
02:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
02:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
02:06.4 Communication controller: Texas Instruments PCIxx12 GemCore based SmartCard controller
08:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5753M Gigabit Ethernet PCI Express (rev 21)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

Anyone have a suggestion?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I know this thread has been dead for quite a while now, but the problem may still exist for some of you, as it did for me until some moments ago. Here is how to get your tty-consoles back if you just get black screens after hitting Ctrl+Alt+F1 to F6:

  1. In a console, run

    sudo apt-get install v86d
    
  2. When installation finishes, open:

    gksudo gedit /etc/default/grub
    
  3. Find the line that reads:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    

    Note: there may be more entries between the ""s, depending on previous changes.

    Replace it with (or expand accordingly):

    GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
    
  4. Find another line which reads:

    #GRUB_GFXMODE=640x480
    

    And replace it with:

    GRUB_GFXMODE=1280x1024
    

    Note: be sure there's no # in front.

  5. Save and close the editor.

  6. Now open:

    gksudo gedit /etc/initramfs-tools/modules
    

    At the end of the file, add the line:

    uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap
    
  7. Save and close the editor.

  8. Finally run:

    FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash && sudo update-grub2 && sudo update-initramfs -u
    
  9. Now reboot. After reboot, your tty-consoles should be accessible again.

Source: crunchbanglinux.org: How to fix tty1-6 (Ctrl+Alt+Fx terminals) if they are not working

share|improve this answer

Per this answer on another site:

I needed to create the file /etc/modprobe.d/radeon-kms.conf, add following line

options radeon modeset=0

and had to restart. Now flickering is gone. :)

share|improve this answer
    
tested this had no effect. flickerign still is there with the native drivers. –  Darkmage Sep 5 '10 at 19:28

I remember that I had that problem a couple of years ago with a computer running an ATI card. IIRC the solution was to give the kernel a different resolution in the boot options.

You can try to add a vga=785 to your boot command. If you hit SHIFT while Ubuntu is starting to load, you should be able to see a GRUB menu. Press 'e' and you must be able to edit the boot command. At the end of the line that starts with "linux" append vga=785 at the end. Hit CTRL+X to boot.

You can try with some other resolutions, you can find instructions to create mode numbers in this wiki.

Note that I can't check this and it's based in my very flawed memory. Hope that it works. Don't hesitate to downvote it if it is just a too wild guess.

share|improve this answer
    
tested, but same problem :/ thx for helping tho :) –  Darkmage Sep 12 '10 at 20:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.