Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 13.10 and have installed compiz settings manager and cairo dock. The top right corner which gives you option for

  1. about this computer
  2. system settings
  3. shutdown
  4. restart
  5. logout and others seems to have a problem

All options are working except shutdown, logout, suspend, restart. Whenever I click on them nothing happens and sometimes this icon disappears from this tray.

How can I fix this?

share|improve this question
    
@olli you really think this question should remain open? –  Braiam Feb 20 at 16:01
    
@Braiam: I'm not sure why it should be closed. Except well, uh, it's bug report, I guess. –  Olli Feb 20 at 16:21
    
@Olli please read this meta.askubuntu.com/questions/8119/… –  Braiam Feb 20 at 16:24
    
@Braiam, thanks, didn't know that. –  Olli Feb 20 at 16:28

2 Answers 2

Though I am not the one who came up with this workaround, it might still be useful for readers of this thread to know about it (posted on https://bugs.launchpad.net/cairo-dock-core/+bug/1242112 by user "Fabounet"):

edit /usr/lib/cairo-dock/cairo-dock-launcher-API-daemon as root
add the following line at line 33:
from time import sleep
and the following line at line 241 (just before ULWatcher()):
sleep(5)

BTW, I use a x86_64 system. In this case, the path of the file is /usr/lib/x86_64-linux-gnu/cairo-dock/cairo-dock-launcher-API-daemon.

Hope it helps.

share|improve this answer

I also had this problem, and I personally did not like the hack proposed at the associated bug report by user Fabounet (cf. UBod's answer), mainly because it means you have to apply the hack again and again each time you update Cairo dock.

I came up with a (in my opinion) cleaner workaround, which I also posted at the bug report. It basically involves adding another item to the panel which also has Shutdown/Logout/Suspend/Restart functionality:

  1. Hold down Super+Alt, right click on the Gnome panel, and click on Add to Panel... in the menu that pops up.

  2. In the drop-down list that appears, look for the item User menu (described as Menu to change your settings and online status), select it, and click Add.

This will add a user menu to your panel. It shows as an item displaying your name with a speech bubble beside it.

The nifty thing is that this item also got menu points for Switch user, Log out and Power off (the latter of which lets you choose between Supend, Restart and Shutdown), and these work, as opposed to the same entries of the "default" gear-wheel item in the upper right corner of the panel.

share|improve this answer
    
Where did you buy your keyboard ? Sorry but I have no "Super" button on mine. –  Tele 22 hours ago
    
Hi. Don't remember where I bought it, but it's a fairly standard one. Most PC keyboards nowadays have a Super key. See this Wikipedia link for a typical keyboard layout with Super key. The Super key oftentimes has a Windows logo on it, as it is the key which opens up the Start menu in Windows. Therefore I think some people refer to it as the "Windows key", though that is a misnaming, particularly in a Linux community. Personally I even glued little Tux'es over the Windows logos ;) –  Malte Skoruppa 20 hours ago

protected by Community Feb 13 at 9:27

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.