Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded from Ubuntu 13.04 to Ubuntu 13.10 and now my WiFi doesn't work. It takes a lot of time to connect but when connected, connection is quickly lost again. In Ubuntu 13.04 worked fine.

Here are some outputs:

lspci | grep Wireless

01:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

sudo rfkill list

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

lsmod | grep rt2800

rt2800pci              18966  0 
rt2800lib              95449  1 rt2800pci
rt2x00pci              13287  1 rt2800pci
rt2x00mmio             13661  1 rt2800pci
rt2x00lib              56053  4 rt2x00pci,rt2800lib,rt2800pci,rt2x00mmio
mac80211              634661  3 rt2x00lib,rt2x00pci,rt2800lib
eeprom_93cx6           13344  1 rt2800pci
crc_ccitt              12707  1 rt2800lib

dmesg | grep rt2800

[   19.959959] rt2800pci 0000:01:00.0: irq 46 for MSI/MSI-X

modinfo rt2800pci | grep 3290

alias:          pci:v00001814d00003290sv*sd*bc*sc*i*

Solution for me:

It appears a Ubuntu bug, I have found a solution here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1049466

Post 117 and +

Thanks

share|improve this question
    
This is all fine. Did you check that modinfo rt2800pci | grep 3290 gave you the output below? –  MariusMatutiae Oct 27 '13 at 10:59
    
Yes it appears be the same. Thank you –  user1857278 Oct 27 '13 at 12:04
    
I found this answer for the same wireless card. The error happens with an older version of ubuntu (12.10 to 13.04) but it seems to be the same problem. Give it a try. –  p2kmgcl Oct 27 '13 at 13:12
    
I have updated my post. –  MariusMatutiae Oct 27 '13 at 14:42
    
I have tried that answer and It fails when I do the make command. I have copied the terminal output here: pastebin.com/JeKm4n5J –  user1857278 Oct 27 '13 at 14:48
add comment

1 Answer

It should be working out of the box with the driver rt2800pci. On my system,

modinfo rt2800pci | grep 3290
alias:          pci:v00001814d00003290sv*sd*bc*sc*i*

which shows the correct Vendr and Product id, see this Wikidevi page. You should first check that you get the same output, then please proceed with these commands:

sudo apt-get install linux-firmware-nonfree
sudo rmmod rt2800pci
sudo modprobe rt2800pci

This should take care of it.

Edit: please post the output of

sudo rfkill list
lsmod | grep rt2800
dmesg | grep rt2800

Edit: we may try to use the backport driver. You should issue these commands:

sudo apt-get install build-essential linux-headers-generic
wget https://www.kernel.org/pub/linux/kernel/projects/backports/2013/10/18/backports-20131018.tar.gz 
tar xvfz backports-20131018.tar.gz
cd backports-20131018
make defconfig-wifi
make
sudo make install
share|improve this answer
    
I have done the commands and I have restarted my computer, but wifi doesn't work. The commands did not get me any output. Thank you –  user1857278 Oct 27 '13 at 10:16
    
I have done these commands and reboot my pc but it is the same, the wifi don't get connection :( –  user1857278 Oct 27 '13 at 15:26
add comment

protected by Community Oct 27 '13 at 18:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.