Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know that there are many posts related but none of them helped me. I will jump to the last test because it is the one that should work, but it does not.

An external HDD with single partition slow NTFS formatted in Windows, empty and clean. Checked for errors, it tells that not errors where found.

Moving to Ubutnu 13.04... Gparted throws the first error when trying to read the disk:

Input/output error

It appears as unknown the content of the disk. Unable to create partition table or format it, getting the same error when trying.

If I try to mount it in the terminal it tells me the same, specifying that also there is an I/O error reading the boot sector.

I have this problem since I upgraded (always with fresh install) to 13.04. I thought it will be solved by the 13.10 but it has the same behavior.

I tried with two different HDD (HD and SSHD) that work perfectly in Windows 7. In 13.04 at least I got a trying of mounting where the icon of the drive started showing and disappearing until finally it disappeared. But now it doesn't even try.

Possible causes: -The HDD was my old main HDD, so it had WIN,RECOVERY,SYSTEM,UBU,SWAP partitions. Maybe the way or place where the partition table is defined is not the best for an external HDD but I don't know a lot in that topic.

I would appreciate a lot if someone can give me a guideline to convert one of these HDD in a working external HDD. No files to recover, nothing to care about. Just format completely the disk and be able to use it for storing backups without having to move the files first to the windows partition, load windows and then copy them to the external HDD. Because I want to use a file comparator for the backups.

Thanks a lot

Edit 1: I found an option in Windows to convert it to a dynamic HDD that warns me that I wont be able to run O.S. after changing. I suppose that is what I need because in the current mode I cannot safely extract it. But it tells me an error that it couldn't change the mode.

Edit 2: ntfs-3g is already installed.

I also tried to connect the HDD back into the laptop, used the live cd of 13.10 with gparted to restore partition table and create new ntfs partition. Same result when connecting back with the usb.

No problems mounting the Windows partition in my laptop's HD. Just with external hard drives I get the errors.

share|improve this question
    
Did youinstall the ntfs-3g package? sudo apt-get install ntfs-3g –  MariusMatutiae Oct 27 '13 at 10:26
    
Welcome to Ask Ubuntu! Please use the contact us link at the bottom of this page to ask for your unregistered account and your new registered account to be merged. Thanks. –  Eric Carvalho Oct 27 '13 at 11:34
    
XaviGG - you appear to have multiple accounts. Please login with your registered account and then click the contact-us link at the bottom of this page to request that your unregistered account is merged. Once done, you will then be able to re-edit your question with further details. Thanks. –  fossfreedom Oct 27 '13 at 12:43
    
Accounts problem solved, I apologize for the inconvenience. –  XaviGG Oct 29 '13 at 12:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.