Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu 13.04 runs on a Virtual Machine (Oracle Virtual Box V. 1. 20). I recently updated my Virtual Box to the recent version and from that time Ubuntu starts in fish shell. At the moment I uninstalled Oracle Virtual Box and installed the former version V.1.20 again.

Still in Ubuntu only starts in the fish-shell (in tty1) and not as it did before in gui desktop. It seems that all my IDE-project-files are still available. I simply tried Ctrl+Alt+F7 without success.

Is anybody having an idea why fish is starting now or a hint how I can start from gui again?

share|improve this question
1  
Have you also installed the add-on tools package? –  hmayag Oct 27 '13 at 10:46
1  
I did that a few minutes ago - situation is the same. I quess that the .vhd-file got corrupted. –  walt Oct 27 '13 at 19:33
    
Take a look at askubuntu.com/questions/305906/… on how to reinstall unity and ubuntu-desktop and askubuntu.com/questions/17610/… on how to reset it. –  hmayag Oct 27 '13 at 21:53
add comment

1 Answer 1

It sounds like you changed your shell to fish. That is, at some point, you did the equivalent of:

chsh -s /usr/bin/fish

Fish is a refreshing change, but it is not compatible with bash. Some of your GUI startup probably depends on bash (or at least sh) compatibility.

Change your shell by running chsh:

chsh -s /bin/bash

You can still run fish either manually (i.e. type "fish" in your terminal, press enter) or by changing the settings of your terminal emulator (e.g. Gnome Terminal) to run fish when it starts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.