Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As the question says: how can I turn on/off compositing (like clicking the appropriate option in System→ Preferences→ Appearance→ Visual Effects) using the command-line?

I run Ubuntu desktop 10.10, if that helps.

share|improve this question
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, – Ringtail Mar 11 '12 at 18:25
up vote 1 down vote accepted

have you tried running

metacity --replace &

then again for enabling run

compiz --replace &
share|improve this answer
This seems to do what I want. I'll mark the question as answered, but I'll wait for more answers (if any). – ΤΖΩΤΖΙΟΥ Mar 12 '12 at 13:15

You can try this command from command line:

gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool false
share|improve this answer
Well, it changes the value (as I can verify through gconf-editor) but, as expected, it has no effect: metacity is not one of the running processes (compiz is running). – ΤΖΩΤΖΙΟΥ Apr 24 '11 at 21:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.