Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to set up a static IP address on my new Ubuntu build (12.04.3 LTS).

I changed the following lines in my /etc/network/interfaces file from:

auto eth0
iface eth0 inet dhcp

to:

auto eth0
iface eth0 inet static
address XXX.XXX.XXX.XXX
gateway XXX.XXX.XXX.XXX
netmask XXX.XXX.XXX.XXX

where the X's are my assigned static IP address, gateway, and netmask. This works fine, and I'm able to connect to the internet. HOWEVER, when I restart, the purple screen comes up for a second, disappears, and then a black screen with flashing white underscore comes up. To resolve this, I've had to modify the GRUB bootloader settings to nomodeset when restarting so that I can get to the desktop.

If it helps, I'm booting off a solid-state drive.

Does anyone know how I can set up a static IP address without compromising my computer's boot-up sequence, or even better, does anyone know why this is occuring?

Please let me know if I can provide any additional information! I'm relatively new to all this and help is greatly appreciated :)

share|improve this question
    
Have you turned off network-manager? It tends to conflict with any manual setup in interfaces, even to the point of just rewriting it. –  ubfan1 Oct 27 '13 at 2:54
    
If simply adding the nomodeset boot option fixes the problem, the problem isn't related to your network/interfaces file. –  Steven Kath Oct 27 '13 at 22:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.