Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install Google-Earth & it requires ia32-libs. So, I did apt-get install ia32-libs but error pops as

Reading package lists... Done Building dependency tree
Reading state information... Done Package ia32-libs is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: lib32z1 lib32ncurses5 lib32bz2-1.0

How to install ia32-libs ? help please. Thank you.

share|improve this question

6 Answers 6

up vote 28 down vote accepted

This is only a workaround until Google Earth is repackaged.

Google Earth Build Package

  1. Download Google Earth x64 .DEB
  2. Open Terminal, Copy & Paste Following Command And Press Enter

    sudo apt-get install libc6:i386 lsb-core
    
  3. Open Downloads Folder

  4. Right Click On Google Earth .deb package & Select Extract Here
  5. Open the folder where files are extracted.
  6. Open the DEBIAN Folder
  7. Open the control file with gedit
  8. Remove this whole Line: Depends: lsb-core (>= 3.2), ia32-libs
  9. Now Click Save, & Exit Control File
  10. Now Delete The Original Google Earth .DEB Package You Downloaded

  11. Create A Folder called getfix, Now Move The Extracted Google Earth Folder Into The getfix Folder

Now we Are Going To Rebuild The Google Earth .deb Package:

  1. Open Terminal, copy/paste the following command then press Enter:

    dpkg -b ~/Downloads/getfix/google-earth-stable_current_amd64
    
  2. Copy/paste the following command (this will install the repackaged .deb)

    sudo dpkg -i ~/Downloads/getfix/google-earth-stable_current_amd64.deb
    
share|improve this answer
3  
Currently, this won't work. The package will install but GE will fail to start. [0324/121420:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses() [0324/121420:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler. Another crash happened while handling crash! –  math Mar 24 at 11:21
    
Same problem here: [0330/183031:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler. –  jgomo3 Mar 30 at 23:01
    
It has worked, this solution works on my Ubuntu 13.10 64bit. –  indago May 8 at 9:14

For Ubuntu 13.10/14.04 64 bit installs

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

Then get the current i386 package & install it - http://www.google.com/earth/download/ge/agree.html

share|improve this answer
2  
Did work (2014-03-24). The 64-bit deb seems to be somewhat broken. –  math Mar 24 at 11:25
    
This even works for PlayOnLinux –  K2Chris1983 Jun 12 at 3:46

After extracting .deb package, I cannot find the Debian folder, so not editing to modify contents line, much less rebuilding the package etc... this is a bit too complicated for non geeks.

Why not simply obtain the 32 bit stable package?:http://www.google.com/earth/download/ge/agree.html

as explained here in ubuntuforums: http://ubuntuforums.org/showthread.php?t=2183733

That worked for me :)

share|improve this answer

This problem has been fixed in Debian Jessie/Sid, since it's not synced with Saucy/Raring I uploaded the fixed versions to googleearth-package PPA:

https://launchpad.net/~absinthesyringe/+archive/googleearth-package

share|improve this answer
1  
Suggesting that people "just use a PPA" is not going to be very safe, as PPAs are third-party, unsupported repositories... –  Thomas W. Nov 10 '13 at 1:17

At the time of writing this answer all the methods described here didn't work. However I installed the 32 bit version and it worked fine on 64 bit 13.10 Kubuntu. It seems that the Google Earth package is 32 bit after all and it uses the ia32libs to make it run on 64 bit. Hope this helps

share|improve this answer

Just install the 32 bit version. It works fine. Here is my reference https://help.ubuntu.com/community/GoogleEarth

share|improve this answer
    
The wiki has/had an incomplete install list for 64bit using 32bit .deb, fixed it –  doug May 2 at 20:59

protected by Community Nov 26 '13 at 2:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.