Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am following along in the docs for installing a new hard drive (the drives are formatted and have data, I'm trying to set up in /etc/fstab)

I'm able to mount normally with

sudo mount /dev/sdb1 /media/photos

when trying to enter into /etc/fstab like so:

/dev/sdb1       /media/photos vfat    defaults 0 0

I get this:

~$ sudo mount -a
[sudo] password for jason: 
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

I tried several variations, like ext3, some of the other options listed in the docs, chaning permissions of the mount point, but always got the same error.

I should also mention this machine is dual booted with win8 and the partitions were created in windows, quite some time ago. (have actually re-installed the OS, both win and ubuntu several times and used these data drives)

from fdisk -l:

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   976769023   488383488    7  HPFS/NTFS/exFAT

and from lshw -C disk:

   description: ATA Disk
   product: WDC WD5000AAKS-0
   vendor: Western Digital
   physical id: 0.0.0
   bus info: scsi@1:0.0.0
   logical name: /dev/sdb
   version: 01.0
   serial: WD-WMASY5272327
   size: 465GiB (500GB)
   capabilities: partitioned partitioned:dos
   configuration: ansiversion=5 sectorsize=512 signature=9eb34acb

any ideas as to what I'm doing wrong?? thanks! bp

share|improve this question
up vote 1 down vote accepted

it appears to be a ntfs partition. change "vfat" to auto in your fstab entry.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.