Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

That behavior is so wrong. The arrow keys should move the cursor, not the panel focus. How to fix it?

share|improve this question
    
Turned me off MonoDevelop so fast. –  Erik Kronberg Apr 23 '11 at 16:40
    
I don't remember having this issue in monodevelop, but I will verify. –  RolandiXor Apr 23 '11 at 18:16
2  
I just checked, and I don't see this occurring on my system :) –  RolandiXor Apr 23 '11 at 18:59
    
@Roland I changed the title to emphasize that I'm talking about the keyboard, not the mouse –  Jader Dias Apr 23 '11 at 20:25
    
I am talking about the keyboard... –  RolandiXor Apr 23 '11 at 21:51
add comment

2 Answers

up vote 1 down vote accepted

Disable IBUS.

This is mostly the cause for such breaks - it's a known bug in the IBUS daemon.

share|improve this answer
add comment

Disable iBUS - confirming Mike Krüger's answer.

You can turn off iBUS per page, by right clicking anywhere on an open page (in Monodevelop), right-click > input methods > None.

I haven't had this issue since I updated to Ubuntu 11.04, but I had it in 10.10. There were a few months where I didn't use Monodevelop so maybe an update during that time fixed it?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.