Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

first of all i know there are a hundred duplicates of this question but i tried EVERYTHING that is written on these posts and the guides refrenced by them but i havnt succeeded yet. i will try to give as many details for best diagnosing of the problem.

i just got a new lenovo thinkpad with pre installed windows 8 64 bit in LEGACY mode. i tried many installations and method but got the same error everytime:

  1. i downloaded and installed wubi on the same partition with windows and got the "no root file system detected" on first run of ubuntu.

  2. i installed wubi on a different partition which i created and formatted in windows and got the same error.

  3. next, i created a liveCD with ubuntu 12.04.3 desktop amd 64 and booted after coniguring the BIOS (UEFI mode, safe boot disabled and quick boot disabled) and the installation didnt detect windows 8.

  4. next, i tried to install ubuntu on legacy mode and the installation didnt detect windows 8.

  5. after all installation attempts i figured from posts in this site that i should partition with "gparted". after burning and booting gparted also didnt detect any partition, it just showed 750GB of unallocated space and no partitions

any one knows what is the problem?

thx in advance.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It sounds like your partition table is damaged. This causes GParted (and the Ubuntu installer, for that matter) to show the partition table as being empty. See my Web page on this topic for more information. If the computer really is booting Windows in BIOS mode (which would be highly unusual for a computer that ships with Windows 8), my FixParts program may be able to fix the problem fairly easily; however, it could be that the problem is caused by leftover RAID data or some other problem.

This type of problem makes me think that the installation may have been adjusted before you got the computer. For instance, if it was an "open-box" special, it could be that the original buyer re-installed Windows in BIOS mode before returning it. This would account for most of the symptoms you report. If this is the case, I recommend completely wiping the hard disk and re-installing Windows yourself, since you don't know what malware that previous buyer might have left behind (intentionally or not). See here for a discussion of legal ways to obtain Windows 8 installation media, if you need them.

One more point: It's my understanding that WUBI has been deprecated. Furthermore, it was always intended for quick temporary or demonstration installations, not for "serious" use. Therefore, I recommend avoiding WUBI. Do a conventional dual-boot installation instead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.