Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to work with ubuntu server remotely using ssh. I have only basic knowledge about linux administration, so it is difficult to work from shell. But any way... When I connected as root via ssh "autocomplete" for commands and folders using Tab and storing of command history works fine.

I created separate user account for me:

sudo useradd andrew
sudo adduser andrew sudo 
sudo passwd andrew

after login as andrew server told me, that home directory for "andrew" doesn't exsist, so

sudo mkdir /home/andrew
sudo chown andrew:andrew /home/andrew

but neither "autocomplete" for commands and folders nor command history doesn't work for this user

Is there any way to make it work?

share|improve this question
1  
Use adduser andrew and not useradd andrew. (You'll see in the man page that useradd is a low-level utility). –  gniourf_gniourf Oct 26 '13 at 7:08
add comment

1 Answer

Maybe your answer HERE

Mateng is close in that I think you're probably running Bourne Shell. But you shouldn't be editing your /etc/passwd file directly. Try using the chsh command instead:

chsh -s /bin/bash The -s flag will make the new shell (Bash in this case) your login shell, going forward.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.