Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I can connect to my house's wireless network just fine, but when I'm connected I can't browse the web. Firefox starts connecting to a site and then just poops out. This doesn't happen on my roommates' computers (running Windows) or on our 3DSes, so I know it's just my laptop.

(Edited to remove irrelevant information)

This other user's answer solved my problem.

I would post this as an answer, but the site keeps converting it to a comment. Thank you for all the suggestions, though!

share|improve this question

marked as duplicate by Seth, Kevin Bowen, LiveWireBT, Warren Hill, Eric Carvalho Oct 27 '13 at 12:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Okay, I've done that. –  A.J. Oct 26 '13 at 3:49
    
Done. (Do I need to comment when I've done it, or can you track edits?) –  A.J. Oct 26 '13 at 4:03
    
You sure the password is correct and that 192.168.0.1 is your router IP? If you are sure, then run sudo dhclient wlan0. And no, any update has to be commented or I don't get a message. –  Braiam Oct 26 '13 at 4:10
    
The password and router IP are correct. Post edited with this output. –  A.J. Oct 26 '13 at 4:14

1 Answer 1

You can open this file:

sudo gedit /etc/modprobe.d/ath9k.conf

And add this line:

options ath9k nohwcrypt=1

Check if this works:

OR

It may be this bug:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/945379

Let us know.

share|improve this answer
    
Thank you, but that doesn't seem to have made any difference. To clarify, my problem isn't with the wireless connection itself. It connects just fine. I just can't browse the web while connected. –  A.J. Oct 26 '13 at 16:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.