Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was following this question but found a problem. Use my webcam with Ubuntu running in VirtualBox

I used guvcview to test the camera, it works. I installed the 12.04 virtualbox release from their website and installed the extension pack. But when I click the usb with the green plus sign it says no devices available.

enter image description here

share|improve this question
    
You sure that the extension pack was correctly installed? Did you reboot both machines? – Braiam Nov 7 '13 at 18:29
1  
might be you didn't add your user to the vboxuser group? – user214636 Nov 11 '13 at 12:04
up vote 57 down vote accepted
+50

This may help you access the USB devices in your guest OS hosted in Ubuntu

First install dkms :

  • sudo apt-get install dkms

Next install Gnome-System-Tools

  • sudo apt-get install gnome-system-tools

Now launch the application - Users and Groups. If you're using unity you can do this by tapping the Super key and type user then click Users and Groups icon to start up the User Settings.

Click Manage Groups, find vboxusers, click properties, add your own user name and any other desired users to the vboxusers group. Click Ok.

Next you'll have to log out (sudo restart lightdm if you're using this DM) and back in. Now start VirtualBox and proceed with adding the USB devices.

share|improve this answer
1  
ajThapa Thanks! It was just that I wasnt in the users group. – Alex Nov 8 '13 at 5:51
    
well scroll still doesnt work – Alex Nov 8 '13 at 5:54
    
Please visit this link: askubuntu.com/questions/152742/… – precise Nov 9 '13 at 3:28
1  
gnome-system-tools ended up being the last piece I needed. I'm on Ubuntu GNOME and had already made sure my user was in the vboxusers group, the latest extension pack was installed, and that USB was enabled for the VM. AFter a final reboot USB devices showed up. – STW Aug 27 '14 at 15:35
1  
I am on xUbuntu 14.04. I did only "Manage Groups, find vboxusers, click properties, add your own user name" + restart (no need apt-get install). It help. Now VirtualBox see all usb devices. Thanks. – msa7 Jul 17 '15 at 4:41

This command will be add your account in vbox users. It will allow your virtualbox to detect USB flash drive.

sudo usermod -G vboxusers -a $USER

$USER value is your username. You can see it with echo $USER

$ whoami
foo
$ echo $USER
foo

You could also replace $USER by your Home username.

Then logout or reboot your computer and VirtualBox will now detect USB devices.

Sources : Virtualbox Documentation on Ubuntu

share|improve this answer
8  
usermod -G ... is error prone, use adduser $USER vboxusers instead. – guntbert Nov 11 '13 at 16:27
    
this is the easiest way. – realhu Oct 12 '15 at 7:19
    
Why is this not the accepted answer instead. The easiest – Rexford Jan 11 at 13:52
1  
what is vboxusers here? adduser: The group 'vboxusers' does not exist. – Abhishek Bhatia Feb 10 at 5:27

It should be enough to run

sudo gedit /etc/group

then find vboxusers line and add to it's end Yours user name.

After this reboot is suggested, but logging out or kill -9 -1 and logging in should be enough.

share|improve this answer

I had the same problem with Linux Mint 17 (Ubuntu 14.04) using the standard distro version 4.3.20. gnome-system-tools and dkms were already installed but open-vm-dkms wasn't. I did this:

sudo apt-get install open-vm-dkms

After a re-boot, I could see the USB devices. The package exists in Ubuntu 12.04 and 14.04 as well so I assume it would work there too.

Could be a dependancy problem?

share|improve this answer

Try this. Once in VirtualBox, click on Devices --> USB Devices --> click on your desired USB device. Do you see the desired device?

enter image description here

share|improve this answer
3  
no. Same thing. Just learned that scroll on mouse doesnt work in it too. – Alex Oct 26 '13 at 18:55

I have Ubuntu 14.04 Lts.Installed 5.0.8 version of oracle Vm and ext. pack.Tried all above solutions.I could't see my usb devices.I downgraded Oracle VM virtualbox and extention pack to 4.3.32 and worked. I am outdated but at least works.

share|improve this answer

My fix was simple...

I had this problem today, and I think it was because I ignored a installation warning about some virtualbox service running. I had to restart my host, but afterward the USB was broken, which brought me here.

I re-installed Virtualbox from scratch, completely removing using "Programs and Features", then installed again.

Now the USB works correctly, I have devices showing up. I had to unplug and replug one of my devices to get it to work within the client however.

share|improve this answer
    
"Programs and Features" is a Windows thing. – The Brown One Feb 19 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.