Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following this question but found a problem. Use my webcam with Ubuntu running in VirtualBox

I used guvcview to test the camera, it works. I installed the 12.04 virtualbox release from their website and installed the extension pack. But when I click the usb with the green plus sign it says no devices available.

enter image description here

share|improve this question
    
You sure that the extension pack was correctly installed? Did you reboot both machines? –  Braiam Nov 7 '13 at 18:29
    
might be you didn't add your user to the vboxuser group? –  user214636 Nov 11 '13 at 12:04

5 Answers 5

up vote 13 down vote accepted
+50

This may help you access the USB devices in your guest OS hosted in Ubuntu (12.04)

First install dkms :

  • sudo apt-get install dkms

Next install Gnome-System-Tools

  • sudo apt-get install gnome-system-tools

Now launch the application - Users and Groups. If you're using unity you can do this by tapping the Super key and type user then click Users and Groups icon to start up the User Settings.

Click Manage Groups, find vboxusers, click properties, add your own user name and any other desired users to the vboxusers group. Click Ok.

Next you'll have to log out (sudo restart lightdm if you're using this DM) and back in. Now start VirtualBox and proceed with adding the USB devices.

share|improve this answer
1  
ajThapa Thanks! It was just that I wasnt in the users group. –  Alex Nov 8 '13 at 5:51
    
well scroll still doesnt work –  Alex Nov 8 '13 at 5:54
    
Please visit this link: askubuntu.com/questions/152742/… –  rusty Nov 9 '13 at 3:28
    
gnome-system-tools ended up being the last piece I needed. I'm on Ubuntu GNOME and had already made sure my user was in the vboxusers group, the latest extension pack was installed, and that USB was enabled for the VM. AFter a final reboot USB devices showed up. –  STW Aug 27 at 15:35

This command will be add your account in vbox users. It will allow your virtualbox to detect USB flash drive.

sudo usermod -G vboxusers -a $USER

You replace $USER by your Home username. Restart your computer and VirtualBox will now detect USB Drive

Sources : Virtualbox Documentation on Ubuntu

share|improve this answer
5  
usermod -G ... is error prone, use adduser $USER vboxusers instead. –  guntbert Nov 11 '13 at 16:27

Try this. Once in VirtualBox, click on Devices --> USB Devices --> click on your desired USB device. Do you see the desired device?

enter image description here

share|improve this answer
1  
no. Same thing. Just learned that scroll on mouse doesnt work in it too. –  Alex Oct 26 '13 at 18:55

Alex to fix your scroll is really simple just disable mouse integration at the lower right hand corner of virtual-box when Ubuntu is running.It look like a computer mouse with a green arrow next to what should be right control or whatever you virtual box super key is.

share|improve this answer

It should be enough to run

sudo gedit /etc/group

then find vboxusers line and add to it's end Yours user name.

After this reboot is suggested, but logging out or kill -9 -1 and logging in should be enough.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.