Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I am trying to install the lib32asound2 (dpkg -i lib32asound2_1.0.25-4ubuntu4_amd64.deb ) package on Ubuntu 13.1 but instead I get this message:

(Reading database ... 224124 files and directories currently installed.)
Preparing to replace lib32asound2 1.0.25-4ubuntu4 (using lib32asound2_1.0.25-4ubuntu4_amd64.deb) ...
Unpacking replacement lib32asound2 ...
dpkg: dependency problems prevent configuration of lib32asound2:
 lib32asound2 depends on libasound2 (= 1.0.25-4ubuntu4); however:
  Version of libasound2:amd64 on system is 1.0.27.2-1ubuntu6.

dpkg: error processing lib32asound2 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 lib32asound2

Could anyone help me out, please?

share|improve this question

marked as duplicate by Seth, Mitch, karel, Aditya, Warren Hill Oct 26 '13 at 10:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
"On newer 64-bit DEB-systems with Multiarch-support (Debian 7) teamviewer_linux_x64.deb cannot be installed because the package ia32-libs is not available anymore on these systems. In this case you can use teamviewer_linux.deb instead." teamviewer.com/en/help/… –  Oleg Svechkarenko Jan 16 at 15:40

1 Answer 1

You've gotten the wrong package for use on 13.10, no need to manually install a downloaded .deb anyway

in terminal

sudo apt-get install libasound2:i386
share|improve this answer
    
Thanks for replying. Basically I am trying to install Teamviewer and it keeps asking for lib32asound and ia32-libs. However, I get the following error for both: Reading package lists... Done Building dependency tree Reading state information... Done Package ia32-libs:i386 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0 E: Package 'ia32-libs:i386' has no installation candidate –  user207639 Oct 26 '13 at 2:18
    
By saying I get the same error I mean that they both end up saying that "E:Package'package-name' has installation candidate" –  user207639 Oct 26 '13 at 2:21
    
    
In the link above it is suggested that Saucy is not quite stable, yet. Could that be the case? –  user207639 Oct 26 '13 at 2:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.