Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just after an update from Ubuntu 10.10 to 11.04 and a restart, Ubuntu freeze at startup on a dialog saying: "It seems that you do not have the hardware required to run Unity. Please choose Ubuntu Classic", etc.

I can not click the "Close" button. I can not switch either to another tty.

Any idea how to figure out what happen?

share|improve this question

closed as off topic by Marco Ceppi Feb 6 '12 at 0:06

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

This question should instead be filed as a bug report, thanks! Instructions here. – Jorge Castro Feb 5 '12 at 23:24

The error means that your 3d graphics are not enabled for Unity to work, OK the error message and go into Classic Desktop and install your 3rd party graphics for nvidia or ati (if that's what you have), then on next boot Unity should work fine...

share|improve this answer
+1 - This sounds like the most obvious answer here. @Séverin Lemaignan - what type of graphics card are you using out of interest? – boehj Apr 30 '11 at 0:26

If it seems you cant use the keyboard and mouse, then, Hold ALT + PrintScreen Keys and type R E. These magic keys will help you to get out of the Frozen Error Box and move into the console. Now Press ALT + F2 to Drop to shell.

Login with your username and password

execute the command, "sudo apt-get update"

execute the command, "sudo apt-get dist-upgrade"

Wait for the operations to complete . Make sure that the downloaded packages are getting installed. If by chance, it fails to download a package, better remove that package and re-run the "dist-upgrade". repeat this till it gets done.

execute "sudo update-grub". Verify that the grub updates its menu with the recent kernel version (2.6.38.x)

Now restart the computer. This should fix the issue

In case you get the same error after re-boot, drop to shell by following the sequence said above. remove the following packages, unity and restart.

share|improve this answer

protected by Community May 6 '11 at 17:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.