Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to have Ubuntu 13.04, and also I had installed VLC 2.1.0 with a .tar.xz archive on that, but after the release of 13.10, I removed 13.04 and installed 13.10, so I tried to install VLC 2.1.0 from the normal PPA:

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc browser-plugin-vlc

...but it installed VLC 2.0.9 for me, so I removed that and tried to install VLC the way I had installed it before on Ubuntu 13.04:

wget -c
tar -xJvf
cd vlc-2.1.0
sudo apt-get build-dep vlc
sudo make install

...but suddenly an error occurred while extracting the .tar.xz file : Error setting owner : Operation not permitted, but the owner of file is me and I changed the all the file's permissions in file properties to read and write, but it doesn't work, so what can I do?

And also if it doesn't work, suggest a good way to install VLC 2.1.0!

share|improve this question
I am using Ubuntu 13.10 and VLC 2.1.0. I tried: $ sudo add-apt-repository ppa:videolan/stable-daily $ sudo apt-get update $ sudo apt-get install vlc – ansidev Oct 25 '13 at 15:59
Do you have permission on the directory? Parent and subs? – fboaventura Oct 25 '13 at 16:02
yes ,the file is directly in my home folder ! and also that ppa installs 2.0.9 for me ! – HOS Oct 25 '13 at 18:29
What's the output of ls -al? – Braiam Nov 2 '13 at 0:56
@guntbert that bug is for file-roller, tar should be unaffected. – Braiam Nov 2 '13 at 0:58
up vote 1 down vote accepted

The tar file seems to have problems, I couldn't figure out why I had to do it in two steps:

  1. I used xz to decompress the file:

    xz -d vlc-2.1.0.tar.xz 
  2. Now I used tar to unpack the tar file:

    tar xf vlc-2.1.0.tar
  3. I can cd to the directory now:

    cd vlc-2.1.0

In a nutshell:

wget -c
xz -d vlc-2.1.0.tar.xz
tar xf vlc-2.1.0.tar
cd vlc-2.1.0

I redownloaded the file and surprise, it worked. Extracting the file with tar Jxf vlc-2.1.0.tar.xz was all I had to do. If for any motive it doesn't work, redownload it.

share|improve this answer
I had no problems with the file: tar xf vlc-2.1.0.tar.xz just worked flawlessly... – gniourf_gniourf Nov 2 '13 at 11:52
Mm... apparently just now I tried, and it worked. But I swear just now it didn't! – Braiam Nov 2 '13 at 12:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.