Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have installed Thunar instead of Nautlius. And now I have nothing on my desktop after reboot. How to solve this problem? I have checked gnome-tweak-tool and "have file manager handle Destop" is ON. Please help. But they exist in Desktop folder

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Thunar doesn't handle the desktop.

You might get this script to work to do what you want, but you might be better of re-installing nautilus and using thunar as the file manager.

share|improve this answer
Thanks, I have reinstalled nautilus. I cannot give you + because I have not reputation enough, sorry. –  Nadir Novruzov Oct 25 '13 at 8:33
Not important to me - as long you've got the help you need:) Not sure if you can accept the answer. –  23 93 26 35 19 57 3 89 Oct 25 '13 at 10:47
@NadirNovruzov Please use the accept answer button to formally accept the answer. –  landroni Jan 15 '14 at 21:37

It is correct that Thunar is currently unable to manage your desktop.

You can re-install Nautilus, but I prefer using NEMO for this.

NEMO will remember exactly where you place your icons on your desktop from session to session. Nautilus does not seem to do that.

Caveat: Unless someone has found an answer that I have not, there is no way to hide the "Computer" and "Home" icons on the NEMO-managed desktop. Clicking on either runs NEMO instead of Thunar.

To use NEMO:

After setting Thunar as your default file manager and uninstalling Nautilus, do two simple steps:

1) install NEMO and 2) open a terminal and enter this:

gsettings set org.nemo.desktop show-desktop-icons true

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.