Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to post to this thread Hardware wireless switch has no effect after suspend and 13.10 upgrade for if I understand their question I am having the same problem, but the answer option won't work for.

After suspend, the wireless is disconnected and the only way to get it to reinitialize/be recognized is to do a full restart.

At first I thought it was my gnome-shell (for lock screen disappeared there with 13.10), but when I switched to the default Ubuntu it's still doing it and it's kinda driving me nuts for I have to reopen all my files and browsers/tabs/windows every time. I don't know how to show the terminal stuff the above asker shows, but it sounds like the same issue and it only started with 13.10 upgrade a few days ago.

Any help would be much appreciated!!! -- Thanks so much, ser.

share|improve this question
    
Possibly useful thread: ubuntuforums.org/showthread.php?t=2004690 –  belacqua May 25 at 3:25
    
There's a bug tracking this here. I added my version of the workaround (as well as a possible alternative), but it might be an idea to subscribe to that bug to learn when you can turn your workaround off. People might also note that the bug affects them in case the Ubuntu devs use that to prioritise fixes. –  Kevin Lyda Jul 7 at 10:54
    
possible duplicate of Problems with networking after suspend –  bain Aug 3 at 14:54

3 Answers 3

I don't know about a official fix of this problem, but

sudo service network-manager restart

works in the meantime.

share|improve this answer

Bof's answer solves the problem in a one off fashion, but these steps solved the longterm issue for me:

sudo touch /etc/pm/sleep.d/wakenet.sh

sudo chmod +x /etc/pm/sleep.d/wakenet.sh

sudo gedit /etc/pm/sleep.d/wakenet.sh

Insert the following lines:

#!/bin/bash
case "$1" in
thaw|resume)
nmcli nm sleep false
;;
*)
;;
esac
exit $?

And then save.

Solution found here

share|improve this answer
    
Welcome to Ask Ubuntu! Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. –  RolandiXor Oct 31 '13 at 15:48
    
Thanks for the tip. I would love to just flag duplicates, but I don't seem to have the authority to do so and want to be able to give other users any assistance that I can. Is there any way for me to be able to mark duplicates for moderator review? Is there some other behavior that I can engage in to be helpful but not create more work for moderators? I'd hate to just leave a person's question languish if I am able to do something to help. –  user208026 Nov 1 '13 at 0:05
    
If you are able to flag at all (with a custom flag, for example), simply mention the two questions that are duplicates. –  RolandiXor Nov 1 '13 at 21:21

I was having this same problem on Ubuntu 14.04 and after a couple of days of trying to fix it, I found a file inside /etc/pm/sleep.d/ which is called 99dw1704.
This file handles disabling and enabling the wl module on hibernate and suspend. All I had to do to fix it is to run: sudo chmod -x /etc/pm/sleep.d/99dw1704 and everything ran fine after this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.