Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before the update (I was using 13.04), editing:

sudo gedit /etc/default/locale

so that LC_TIME="en_GB.UTF-8" does the job.

However in 13.10, this does not work anymore.

I've tried editing:

sudo gedit /usr/share/i18n/locales/en_AU
sudo gedit /usr/share/i18n/locales/en_GB
sudo gedit /usr/share/i18n/locales/en_US

so that first_weekday 2 in each of the files, but this also does not work.

As a reference, when I run locale, the output is

LANG=en_AU.UTF-8
LANGUAGE=en_AU:en
LC_CTYPE="en_AU.UTF-8"
LC_NUMERIC=en_AU.UTF-8
LC_TIME=en_AU.UTF-8
LC_COLLATE="en_AU.UTF-8"
LC_MONETARY=en_AU.UTF-8
LC_MESSAGES="en_AU.UTF-8"
LC_PAPER=en_AU.UTF-8
LC_NAME=en_AU.UTF-8
LC_ADDRESS=en_AU.UTF-8
LC_TELEPHONE=en_AU.UTF-8
LC_MEASUREMENT=en_AU.UTF-8
LC_IDENTIFICATION=en_AU.UTF-8
LC_ALL=

Please help.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

If LC_TIME is en_GB.UTF-8 in /etc/default/locale, and the locale command still states en_AU.UTF-8, you have user specific settings that override the system wide settings in /etc/default/locale.

Assuming that you live in Australia, and want regional format settings in general reflect what's typical in Australia, you can try to edit your ~/.profile file and add this line:

export LC_TIME=en_GB.UTF-8

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.