Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Ubuntu 13.04, I suddenly found that though I can login, I am immediately blocked by XScreenSaver. So, I can no longer get into my account.

I do have the root password if needed, and can get into another account.

How do I disable/remove XScreenSaver?

share|improve this question
    
Is the other account in the admin group? That means, can you use sudo with this account? –  the_Seppi Oct 24 '13 at 19:35
    
I think so. But I can't get into it. –  Joshua Fox Oct 24 '13 at 22:51
    
Hit Ctrl+Alt+F1 and you can login... –  the_Seppi Oct 25 '13 at 9:25
add comment

1 Answer

up vote 2 down vote accepted

Execute this command to remove Xscreensaver

sudo apt-get autoremove xscreensaver
sudo apt-get --purge remove xscreensaver

To disable, you've to go to:

in gnome

system->preferences->Sessions->Startup Programs

and delete the entry of xscreensaver.

Also give a look at System -> Preferences -> Screensaver

in Unity

Search Brightness and Lock in dash, and just click Off under Lock, you can set configurations according to your need.

More help

man xscreensaver
share|improve this answer
    
Thanks. I'll try removing xscreensaver. However, I can't disable it (in Lubuntu), because it is locking me out! –  Joshua Fox Oct 24 '13 at 22:52
    
I didn't know you were using Lubuntu. For Lubuntu, I really don't know how to disable. :( Although I'll try my best to find the way to disable. –  Saur.K Oct 24 '13 at 22:56
    
Thanks, removin xscreensaver, after logging into another account, did it. –  Joshua Fox Oct 25 '13 at 12:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.