Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I want to do iPhone tethering using MyWi, I can see the network it creates but I just can't join. Having WEP security on would throw me into the passphrase input again and leaving it unprotected doesn't connect.

share|improve this question
add comment

marked as duplicate by Luis Alvarado Mar 14 '13 at 17:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

Ad-Hoc network in Ubuntu are a little tricky. I had to set one up myself and it took me a while to realize how silly the solution is!

The problem is, even after you declare the connection ad-hoc, the ad-hoc infrastructure is not selected by NM. (come to think of it, maybe I should file a bug against that)

The solution is to right-click on the nm-applet, select Modifying connexions (translating from french, so option name might differ a little bit here), and go to the Wireless tab. Click on your Connection's name and click edit. Now, make sure the Mode is set to Ad hoc and the IPv4 and IPv6 tabs methods are set to "local link only"

after this, it should work. If not, let us know!

share|improve this answer
    
Yes I have heard of the 'not set to ad-hoc' issue. It does this for me at times too and should be the solution. –  NightwishFan Sep 24 '10 at 1:40
add comment

Make sure you are using it with the correct security type. Most keys are 40/128bit.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.