Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Fuji camera mount reported in attached devices but not visible in Dolphin After Kubuntu 13.10 upgrade

Have reinstalled the driver, and a few other suggestions, for other cameras mounts failing on previous Ubuntu upgrades.

I have already spent a couple of hours trying to get my photo's off the camera, very annoying.

Worked perfectly in 11.04, 11.10, 12.04, 12.10 and 13.04.

dmesg | tail; lsusb; lsb_release -a
[ 6181.858786] CPUM: APIC 03 at 00000000fee00000 (mapped at ffffc90009400000) - ver 0x80050010, lint0=0x10700 lint1=0x10400 pc=0x00400 thmr=0x10000
[17261.396236] CPUM: APIC 00 at 00000000fee00000 (mapped at ffffc90000c6a000) - ver 0x80050010, lint0=0x10700 lint1=0x00400 pc=0x00400 thmr=0x10000
[17261.396239] CPUM: APIC 03 at 00000000fee00000 (mapped at ffffc90000c72000) - ver 0x80050010, lint0=0x10700 lint1=0x10400 pc=0x00400 thmr=0x10000
[17261.396241] CPUM: APIC 02 at 00000000fee00000 (mapped at ffffc90000c70000) - ver 0x80050010, lint0=0x10700 lint1=0x10400 pc=0x00400 thmr=0x10000
[17261.396255] CPUM: APIC 01 at 00000000fee00000 (mapped at ffffc90000c6e000) - ver 0x80050010, lint0=0x10700 lint1=0x10400 pc=0x00400 thmr=0x10000
[32456.884907] usb 2-5: new high-speed USB device number 2 using ehci-pci
[32457.654046] usb 2-5: New USB device found, idVendor=04cb, idProduct=01e8
[32457.654050] usb 2-5: New USB device strings: Mfr=0, Product=2, SerialNumber=3
[32457.654052] usb 2-5: Product: Digital Camera
[32457.654053] usb 2-5: SerialNumber: 4C3230302020091117CAA59WP18548
Bus 002 Device 002: ID 04cb:01e8 Fuji Photo Film Co., Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 2013:024f PCTV Systems nanoStick T2 290e
Bus 001 Device 002: ID 046d:082d Logitech, Inc. HD Pro Webcam C920
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
No LSB modules are available.
Distributor ID: Ubuntu
vissibleDescription:    Ubuntu 13.10

Release: 13.10 Codename: saucy

sudo apt-get install gvfs-bin

gvfs-mount gphoto2://[usb:002,002]

Error mounting location: 
Error initializing camera: -108: 
No such file or directory

......

I have reported a bug in Dolphin, which has been transferred to Solid.

Further information : I ran solid-hardware list details

udi = '/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:04.1/usb2/2-5' 

parent = '/org/kde/solid/udev' (string) 

vendor = '04cb' (string) 

product = 'Digital Camera' (string) 

description = 'Camera' (string) 

Block.major = 189 (0xbd) (int) 

Block.minor = 137 (0x89) (int) 

Block.device = '/dev/bus/usb/002/010' 

(string) Camera.supportedProtocols = {'ptp'} 

(string list) Camera.supportedDrivers = {'gphoto'} 

(string list)

I still can't get my photo's off, I can see the folders using the Gimp menu.

If anyone has got any ideas, I'm willing to try them.

> Update>, Still need help, its impracticable to get photos of a camera from Gimp menu.

My only option is to use a different PC (12.04 or w*ndowes.) and copy it back of that.

I will try any suggestions to fix 13.10.

> Update 17th November, NO IDEAS TO TRY????????? Update 2 December 2013, No Ideas to try, yet!

share|improve this question
    
Perhaps it will help to take a look at bugs.kde.org/show_bug.cgi?id=264020 –  chandra Jan 7 at 18:07
add comment

2 Answers 2

Not sure that my problem is the same and am still searching the net for possible solutions. Both of my FujiFilm digital cameras, an XP 30 GPS and an XP 100 do not mount into file managers. Not into PCManFM, not into Nautilus, nor Gnome commander. The images can be imported by ShotWell and the circa 2003 camera-app application. I am running Lubuntu 13.10, the cameras did mount into file managers under 13.04. I am not convinced that this is a bug as the system has been upgraded since 12.04 and has a complex package history. In a 2012 attempt to mount an older USB device, the system had usbmount among other packages. These were pulled as they mounted USB drives as root and made the unwriteable for users. I am thinking that the problem is somehow related to the USB PTP. ghoto2, gtkam, photopc, and gphotofs are all on board (everything including the kitchen sink approach).

Shotwell is slow to transfer photos, camera-app is really fast. Not sure if that is related. You note that GIMP can see the folders, maybe one of those apps can also get your photos off.

Have yet to find a Launchpad bug that appears to describe the problem.

share|improve this answer
add comment

Finally, it was fixed / fixed itself in 14.04. I can now copy files from my camera again.

It would be interesting to know what was wrong, why we couldn't patch it, otherwise it could happer again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.