Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was reading today the latest Canonical design blog post where I was kind of surprised that one should be able to right click on the desktop to change the wallpaper. I am running the most updated version of natty and have the latest unity package installed (3.8.10) but right clicking on the desktop brings nothing on my machine. On the other hand, when I right click on any launcher icon I do get a quick list, so I know it's not a problem with my mouse or something. Is this a known bug?

I tried to kill Nautilus as Nathan suggested using Alt+F2 and then killall nautilus. Just to be sure, I then opened a terminal window and typed the same command again. Got the response nautilus: no process found (I figured that my first try to kill nautilus worked then. Just to be on the safe side, I clicked the "Home" icon on my launcher to start Nautilus, and then killed it again (same command). Still nothing happened.

Following some of the comments below, I should specify that I do have ubuntu-desktop installed (and updated version 1.220) and nautilus is indeed installed (Version: 1:2.32.2.1-0ubuntu13). (Used to have nautilus from the elementary PPA, but removed it following the comments below - still no luck).

share|improve this question
    
Do you have nautilus managing your desktop? Or have you disabled that option? –  RolandiXor Apr 22 '11 at 21:33
    
Roland, thanks for the quick reply. How do I know if I have nautilus managing my desktop? As I was unaware of this option, I guess I never changed that. Following yours and Nathan response below, I should mention that I am using nautilus-elementary. Can this be the culprit? –  S B Apr 22 '11 at 21:46
    
I removed my installed version of nautilus (from the elementary PPA) and reinstalled nautilus (Version: 1:2.32.2.1-0ubuntu13). Logged out and back in, and still - right clicking has no effect whatsoever –  S B Apr 22 '11 at 22:19

3 Answers 3

up vote 6 down vote accepted

It is highly unlikely the N.E. is a real problem.

Ensure that:

/apps/nautilus/preferences/show_desktop enter image description here (run gconf-editor) Is set to true. If it is, also ensure that nautilus is set to launch on login.

share|improve this answer
    
@Roland, you solved it for me! Thanks!! I also realized why was this turned off on my machine. I am using Ubuntu Tweak which gives you an option to have a desktop "without icons". I guess this option turns off the "show desktop" setting of nautilus. Thanks again! Heading back to reinstall nautilus from the elementary PPA... :-) –  S B Apr 22 '11 at 23:18
    
@SB: I figured you had used Ubuntu-Tweak, but I didn't want to mention it if you did not have it. –  RolandiXor Apr 23 '11 at 4:23
    
posted a bug report on the Ubuntu Tweak launchpad page. –  S B Apr 24 '11 at 11:38
    
@SB: this is not a bug in ubunu-tweak, but in Nautilus. –  RolandiXor Apr 24 '11 at 12:10
    
@Roland, actually, I thought this wasn't actually a bug, but a desired behavior. The bug report which I posted against Ubuntu Tweak is not of some malfunctioning code, but just a suggestion that when a user unchecks the relevant chackbox he is notified that his desktop will no longer be clickable. See bug report for details of what I suggested. Why do you see it as a bug with Nautilus? Maybe Nautilus should differentiate between not showing icons, and making the desktop unclickable? –  S B Apr 24 '11 at 20:05

The desktop is actually provided by Nautilus, just like it was in previous versions of Ubuntu. If you press Alt-F2 and type "killall nautilus" without the quotes and then press Enter, this will stop (and automatically restart) Nautilus. What happens when you right-click on your desktop then?

share|improve this answer
    
Nathan, thanks for the quick response. I tried what you suggested and nothing happened - did not get any feedback from the system, and right clicking the desktop still did not work. Just to be sure, I then opened a terminal window and typed the same command again. Got the response nautilus: no process found (I figured that my first try to kill nautilus worked then. Just to be on the safe side, I clicked the "Home" icon on my launcher to start Nautilus, and then killed it again (same command). Still nothing happened. One last thing that may be important. I am using nautilus-elemenatary –  S B Apr 22 '11 at 21:42
    
@SB It is likely nautilus is not installed, ensure that the ubuntu-desktop package is installed, that should install everything you're supposed to have. –  Jorge Castro Apr 22 '11 at 21:44
    
@SB You're quite welcome! I should've mentioned that, too. You can run nautilus from Alt-F2 as well, although I recommend opening a Terminal and running it from there. 'nautilus &' should work. Running nautilus from the launcher runs it in windowed mode. And as Jorge said, installing the ubuntu-desktop package could help. You can do that in a Terminal with 'sudo apt-get install ubuntu-desktop' –  Nathan Haines Apr 22 '11 at 21:48
    
@Jorge, @Nathan, thanks for looking into this. I do have ubuntu-desktop installed (and updated version 1.220) and nautilus is indeed installed (1:2.32.2.2-0ubuntu3~ppa170 - from the elementary PPA). So, let me ask again, can this be the probable cause? –  S B Apr 22 '11 at 21:55
    
@SB Add the version information to your question. I'm guessing N-E is the cause but someone with more expertise will at least have the information up front. –  Jorge Castro Apr 22 '11 at 21:57

If you have gnome tweak tool installed, go ahead and press Alt + F2, type in "Gnome Tweak" and you should see a tweak tool. Open that, go to the desktop section and turn on Desktop. Worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.