Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The other day I was asked to upgrade from 13.04 to 13.10, at the time I was busy and hit no. I can not upgrade/update at this point, I get (error -11) or a 404 in terminal. In the software updater I get 'failed to download repository information.'

I have tried changing my "Download From" setting to "Best" to "Main" and even a few other countries. And in "Other Software" I have tried disabling packages, but doesn't seem to help what so ever. I have tried several of the other commands to try and fix it, such as -fix missing or sudo apt-get update clean.

P.S. This has also affected my thunderbird client, I cannot send/receive emails.

Here is my error log when trying to upgrade:

jakob@Skeletor:~$ sudo update-manager -d

gpg: /tmp/tmpvejqvl/trustdb.gpg: trustdb created
gpg: /tmp/tmpnayby6/trustdb.gpg: trustdb created
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
    result = gen.throw(excep)
  File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 86, in commit
    True, close_on_done)
  File "/usr/lib/python3/dist-packages/defer/__init__.py", line 483, in _inline_callbacks
    result = gen.throw(excep)
  File "/usr/lib/python3/dist-packages/UpdateManager/backend/InstallBackendAptdaemon.py", line 158, in _run_in_dialog
    yield trans.run()
aptdaemon.errors.TransactionFailed: Transaction failed: Package does not exist
 Package linux-headers-3.8.0-33 isn't available
gpg: /tmp/tmp3kw_hl/trustdb.gpg: trustdb created.

And let me throw in my sudo apt-get update too. Which this has been working variably too, but I don't know what to change my repositories to, and disabling does not effect:

 E: Some index files failed to download. They have been ignored, or old ones used instead.

This is the short version, but looks exactly like this fairly consistently. Sometimes it downloads, sometimes it doesn't. Sometimes it tells me I have an update, and doesn't do anything.

If it helps, I have recently had issues trying to install Samba as well, and connecting to the office's NAS Drive. Which works now, but I had to edit /etc/fstab/ and a few other things trying to get that to work as well. I understand it could also be a DNS problem, but this has been going on for a few days, as well as I've already tried changing my DNS server via my computer, however I am not allowed to alter the DNS on our company's router.

share|improve this question
1  
What happens when you disable the two Launchpad ppa's? They could be down. You can re-enable them as soon as you upgrade. –  searchfgold6789 Oct 24 '13 at 15:15
    
If I disable them, such as my "wine ppa" it will still continue trying to update, its kinda bizarre. I am not a linux-expert by any means, but I have a rough idea of how it all works –  Jakob Oct 24 '13 at 15:30
    
You still get the "something wicked happens" errors when you disable them and run sudo apt-get update? –  searchfgold6789 Oct 24 '13 at 16:10
    
Yes, those vary based upon server, but not based upon which packages I have selected. (If I turn off wine, it still tries to update that). –  Jakob Oct 25 '13 at 5:50
add comment

1 Answer

it appears that you have mixed packages 32 and 64 bits. Your kernel is improperly installed : linux-headers-3.8.0-33

Desactive ppa and launch this command :

sudo apt-get install -f 

Send the result

share|improve this answer
    
First: i.imgur.com/IPao79g.png –  Jakob Oct 24 '13 at 17:10
    
Second: i.imgur.com/klQ24Vq.png Wasn't sure which I should disable, so I did both, same results. –  Jakob Oct 24 '13 at 17:10
    
Does this help at all? When I was trying to connect to my NAS drive in the office, I did edit quite a few internet related settings. I cannot remember all of them, but I have already restored /etc/fstab to its default (and I don't think that was the problem either). Deleting the lock files will help temporarily. –  Jakob Oct 26 '13 at 19:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.