Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran:

%> sudo add-apt-repository ppa:chris-lea/zeromq
%> sudo aptitude update
%> sudo aptitude install zeromq3 php-zeromq # result: zeromq3 - no such package found

I tried restarting my system, running sudo apt-get update, restarting again, but in all cases I get the same package not found result.

I have verified that these packages exist for 12.04 by filtering for Precise from the "Published in:" dropdown at the Launchpad.net page.

What do?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

ZeroMQ3 cannot be installed with a single zeromq3 package. I don't know why. You can still install ZeroMQ3 with 3 packages (libzmq3-dbg, libzmq3-dev and libzmq3) separately. So the complete solution is:

sudo add-apt-repository ppa:chris-lea/zeromq
sudo apt-get update
sudo apt-get install libzmq3-dbg libzmq3-dev libzmq3

How to know these packages are libzmq3-dbg, libzmq3-dev and libzmq3? You can go to https://launchpad.net/~chris-lea/+archive/zeromq and click View package details, then click the package you desired. You'll see them in Built packages section.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.