Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Yesterday I was finally able to install ubuntu 12.04.3 (64 bits) on my pre-installed Windows 8 (64 bits) Lenovo Ideapad Z500 (if that is of any help). I'll just explain the problem that I have now and if you need more info just ask me (such as the steps I followed to install Ubuntu, etc.) So I boot the computer (UEFI Bios, SecureBoot Disabled, Fast startup on Windows 8 disabled) and GRUB appears correctly (I already ran BootRepair to achieve this), then if I choose Ubuntu, it loads correctly. The problem is when I choose Windows 8 I receive this error:

unknow command `drivemap'
invalid EFI file path

Furthermore, in GRUB I see 2 Ubuntu Boot options alongside many windows options and I just discovered that clicking one: "Windows Boot UEFI Recovery" actually boots my Windows 8 as usual. So, I actually have a working dual boot, but instead of choosing "Windows 8 (loader)" which doesn't boot Windows 8 (and just shows the drivemap error) I have to select the mentioned "Windows Boot UEFI Recovery" option to correctly boot windows 8. Is there any way to solve this issue?? Thanks in advance!!

Cheers, Alejandro.

P.S.: The BootInfo generated by BootRepair can be found here http://paste.ubuntu.com/6294680

share|improve this question

marked as duplicate by Luis Alvarado Mar 4 at 17:08

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Hi @beta3designs I have updated the marked duplicate question with several steps to fix Dual Boot issues. This are tested and work correctly for cases like yours apply. –  Luis Alvarado Mar 4 at 17:08
add comment

2 Answers 2

You originally installed Ubuntu in BIOS mode, since you have grub in the protective MBR. But Boot-Repair converted your install to UEFI by uninstalling grub-pc for BIOS and installed grub-efi for UEFI.

Boot-Repair also added boot entries for Windows in 25_custom and you and manually edit those if the titles are not correct. It had to add new entries as grub has a bug and only creates BIOS boot entries even for UEFI systems. New 13.10 has a fixed grub2 os-prober that does it correctly.

gksudo gedit /etc/grub.d/25_custom

Boot-Repair also did the Windows filename rename. Rod Smith calls it a hack, I consider it a work around for buggy BIOS, but think Boot-Repair may be running it when not required. But we do not know if your UEFI would alllow booting of Ubuntu from UEFI. The rename is for those UEFI that only boot Windows. So it renames grub2's shim file that has the Microsoft signing key to the Windows file name and you boot the Windows efi file from grub menu that has bkp at beginning of name.

If your want to undo rename. But if then you cannot boot you may have to add the rename again. May be best to have full backup of efi partition.

To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair.

share|improve this answer
add comment

The easiest and safest solution is to ignore the "Windows 8 (loader)" GRUB entry and just use the ones that work.

If that offends you, you can try adjusting your GRUB menu entries. This is more complex than it should be, unfortunately. Googling a phrase such as "adjusting GRUB 2 entries" produces about a bazillion hits with information on this topic, but I haven't read them in enough depth to recommend any specific site. There is a GUI tool called GRUB Customizer that's supposed to simplify matters, but I've never used it, so I can't comment on how well it works.

Another option is to move away from GRUB entirely. In particular, my rEFInd boot manager is much easier to configure manually; however, when you first install it, it's likely to have more, not fewer, extraneous entries. If you want to remove them, you'll need to remove files in the /boot/efi/EFI/*/ and/or /boot directories or use the dont_scan_files and dont_scan_dirs options in the refind.conf configuration file to keep boot files out of the menu.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.