Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Nemo from the Ubuntu 13.10 Saucy repositories, and replaced Nautilus with it as shown here:

$ xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search
$ gsettings set org.gnome.desktop.background show-desktop-icons false
$ gsettings set org.nemo.desktop show-desktop-icons true

Now, when I start Nemo from the Unity Launcher, it places its window below other windows on the screen. I want Nemo to start like Nautilus did, and every other application, in the foreground.

share|improve this question

1 Answer 1

I started to experience the issue with other apps later, and then I began to search for solution not for Nemo, but in general, and found one on the Ubuntu Forums, and two on Ask Ubuntu as well.

This is caused by Compiz, so you have to use compizconfig-settings-manager (sudo apt-get install compizconfig-settings-manager, then start ccsm command with Alt+F2, or from terminal, or search for "CompizConfig Settings Manager" from the dash).

  1. Open "General Options"
  2. Under "Focus and Raise Behaviour" tab set Focus Prevention Level to Off

After following these steps, all my newly opened windows show up in the foreground as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.