Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When upgrading Ubuntu 13.04 to Ubuntu 13.10 (64 bit), the upgrade tool insisted on removing Skype.

I'm now trying to get Skype reinstalled. When trying from the software center (as suggested by why doesn't Skype start?), I get a dependency problem:

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

So let's try apt-get as usual:

janr@guzumi:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: ia32-libs (>= 20080808) but it is not installable
         Depends: lib32asound2 (> 1.0.22) but it is not installable
E: Unable to correct problems, you have held broken packages.

It seems ia32-libs was removed from Ubuntu. Installing with "apt-get install skype:i386" works, but then I get a segmentation fault when starting Skype. As my system is 64 bit, I removed skype:i386 again.

Moreover,

janr@guzumi:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32asound2 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

I found another page (http://www.webupd8.org/2013/10/get-sound-working-in-skype-with-ubuntu.html) saying I should really try to use Skype from the Ubuntu version, as it has a fix for the sound library which is not present in the version offered by Skype itself. So I refrain for now from trying that.

share|improve this question
    
Install this sudo apt-get install ia32-libs , After installing this install the skype –  Lonston Oct 24 '13 at 10:39
2  
@Babinlonston that won't work, ia32-libs was removed in favor of multiarch stuff, so your "comment" is no longer relevant and will never work. –  Thomas W. Jan 1 at 0:03

6 Answers 6

You could just download and install the Debian file from the Skype website. It works fine for me (Ubuntu 13.10 64 bit), but it is a clean install.

share|improve this answer
    
does your audio work? Mine keeps making a sound similar to a truck horn. –  KI4JGT Nov 8 '13 at 19:42

Installing ia32-libs manually

You can try installing ia32-libs's dependencies manually. It was only ever a metapackage depending on various 32-bit libraries. This may or may not work, if Skype really insists depending on ia32-libs, this will not work even though all the required libraries are installed.

Run this command in a terminal (triple click to select the whole line):

sudo apt-get install bluez-alsa:i386 libgettextpo0:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386 gtk2-engines:i386 gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386 gtk2-engines-oxygen:i386 gvfs:i386 ibus-gtk:i386 libacl1:i386 libaio1:i386 libao4:i386 libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libattr1:i386 libaudio2:i386 libcanberra-gtk-module:i386 libcap2:i386 libcapi20-3:i386 libcups2:i386 libcupsimage2:i386 libcurl3:i386 libdbus-glib-1-2:i386 libesd0:i386 libfontconfig1:i386 libfreetype6:i386 libgail-common:i386 libgconf-2-4:i386 libgdbm3:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgtk2.0-0:i386 libmpg123-0:i386 libncursesw5:i386 libnspr4:i386 libnss3:i386 libodbc1:i386 libopenal1:i386 libpulse-mainloop-glib0:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-opengl:i386 libqt4-qt3support:i386 libqt4-script:i386 libqt4-scripttools:i386 libqt4-sql:i386 libqt4-svg:i386 libqt4-test:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 librsvg2-common:i386 libsane:i386 libsdl-mixer1.2:i386 libsdl-image1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386 libsdl1.2debian:i386 libsqlite3-0:i386 libssl0.9.8:i386 libssl1.0.0:i386 libstdc++5:i386 libstdc++6:i386 libxaw7:i386 libxml2:i386 libxp6:i386 libxslt1.1:i386 libxss1:i386 libxtst6:i386 odbcinst1debian2:i386 libpulsedsp:i386 xaw3dg:i386 libpam-ldap:i386 libpam-ldapd:i386 libpam-winbind:i386 libnss-ldap:i386 libnss-ldapd:i386 libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgphoto2-port10:i386 libgphoto2-6:i386

The above command was compiled from the list of ia32-libs-multiarch dependencies as reported by apt-cache depends ia32-libs-multiarch on Ubuntu 13.04.

NOTE: While I've verified that all the packages exist, it is entirely possible that those with version numbers in the package name (e.g. gstreamer0.10-plugins-base:i386) have a new version available under a different package name.

share|improve this answer
    
I don't think this is valid on Ubuntu 13.10. At least, it isn't valid for me. –  Ehtesh Choudhury Dec 30 '13 at 18:17
    
@Shuran what error do you get? –  minerz029 Dec 30 '13 at 21:00
    
Not in front of the same computer to verify, but I wasn't able to install lib32zl1 –  Ehtesh Choudhury Dec 31 '13 at 19:23
    
@Shurane I'll try working on a workaround –  minerz029 Dec 31 '13 at 22:15
    
This is what I get, @minerz029: sprunge.us/CIPP –  Ehtesh Choudhury Jan 1 at 5:02

Execute:

sudo dpkg --add-architecture i386

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

sudo apt-get update && sudo apt-get install skype

This will resolve all the dependencies and install the package provided in the Canonical Partner repository. More information in this link.

share|improve this answer
2  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  minerz029 Jan 1 at 0:55

Indeed I only managed to have working video in SKYPE with the command in a terminal:

PULSE_LATENCY_MSEC=30 LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

However, this only worked after installing the ia32-libs package [for an explanation of what happened see here], which I did using the following procedure from here:

Here is a workaround using ia32-libs from a previous distribution (13.04). This has been tested with the release candidate of 13.10 and all is well and functional.

Install Synaptic from terminal window:

sudo apt-get install synaptic

Launch synaptic and goto “settings > Repositories” click “other software > add” insert this line in the box:

deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

Click OK and close synaptic. In terminal

sudo apt-get update && sudo apt-get install ia32-libs
share|improve this answer

I just had this same issue - running Xubuntu x64 on Acer C720. I almost always install; using terminal (dpkg). Had notification of dependencies issue though.

When I opened Software Center, it automatically queried me to "repair" the installation. After repair Skype works fine. Obviously not moving to 14.04 for a while until I hear that C720s are fully supported/nearly fully supported on Tahr.

Hope this helps.

share|improve this answer

I enabled the Canonical Partners repo in Ubuntu Software Center (as someone else mentioned), and then did:

sudo apt-get update
sudo apt-get install skype:i386

This automatically grabs all the dependencies for the 32 bit version of Skype. You don't need to figure that stuff out yourself.

edit: I reread the OP - "apt-get install skype:i386" was apparently already tried. I didn't get a segfault; it ran fine. Perhaps the Skype package has been updated and the segfault was consequently fixed.

share|improve this answer

protected by Community Apr 17 at 3:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.