Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since I've updated to Kubuntu 13.10 my brightness level is at 100%. I already googled around and tried different tips, but none of them worked.

I've edited /etc/default/grub to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
acpi_osi="linux"

Also I've tried uninstalling and reinstalling the proprietary ATI Fire GL driver, but I think I've completely messed up the system by doing so, because now the /sys/class/backlight/ directory is empty which wasn't before. Unfortunately I don't know how to get it back. Also since then the settings for adjusting the screen brightness in the power management are gone.

I have a Toshiba Satellite Pro notebook. Naturally the FN keys for adjusting the brightness don't work either, but worked fine on 13.04.

I'd be glad if someone could help me there since my eyes can't handle this brightness. ;)

Edit: I've solved this by following the steps in 2.1 of https://help.ubuntu.com/community/BinaryDriverHowto/ATI for un-installing the installed driver. In short I did the following:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.BAK

sudo apt-get remove --purge fglrx fglrx-amdcccle

sudo apt-get remove --purge fglrx-updates fglrx-amdcccle-updates

After the reboot my screen went black. First I was afraid I messed something up, but then I tried using the FN-keys to bring up the brightness and they worked!

Then I followed the rest of the steps in 2.1 and installed the drivers again, but after the restart, the brightness was stuck at 100% again, so I did the un-installation steps again and the brightness control works again.

I'm just not sure if I should try installing the Catalyst drivers directly from the AMD's page or not. But for the moment everything seems to be ok, except of the fact that I'm running with the default drivers.

share|improve this question
    
As a workaround try this: sudo xrandr --output LVDS --brightness 0.3 –  bfootdav Oct 25 '13 at 19:02
    
Thank you @bfootdav, this works. But it seems to make everything blurry.... Is there any other way to control the brightness? –  Johnnie Walker Oct 27 '13 at 10:25
    
I'm in the exact same boat as you and I haven't found anything. My Toshiba with ATI card was working perfectly with 13.04 but now with 13.10 all sorts of things are broken including setting the brightness. You're supposed to be able to use xbacklight (it works on the hardware level as opposed to the software level of xrandr) but I (and many others, it appears) have been unable to get it to do anything. It's frustrating. –  bfootdav Oct 27 '13 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.