Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello I am new here and I have been trying to install wine:

$ sudo apt-get install wine1.7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7 : Depends: wine1.7-i386 (= 1.7.4-0ubuntu4) but it is not installable
E: Unable to correct problems, you have held broken packages.

what should I do ?

share|improve this question

marked as duplicate by Avinash Raj, Eliah Kagan, BuZZ-dEE, karel, Braiam Jan 19 '14 at 15:51

This question was marked as an exact duplicate of an existing question.

You're trying to install a latest version of wine! Are you sure this version is in your repository? Did you add a new repository to install the latest version of wine? like: sudo add-apt-repository ppa:ubuntu-wine/ppa ? Reply.. – Saurav Kumar Oct 24 '13 at 3:01
See here: – minerz029 Nov 3 '13 at 0:23
What is the output of sudo apt-get check and apt-cache policy wine1.7 wine1.7-i386, – Braiam Jan 19 '14 at 15:51
up vote 0 down vote accepted

Follow these steps to install wine1.7

  • open terminal and execute these commands:

    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.7

    if again last command gives you some error then replace it by:

    sudo apt-get install wine1.7 wine1.7-i386"=1.7.4-0ubuntu4"
  • It should successfully install wine without any problem. :)

Reply if something goes wrong..

share|improve this answer
Tried them both (with wine 1.7.8 instead). It still fails with the same error. – Madara Uchiha Dec 21 '13 at 12:22
@MadaraUchiha: it happens because of the installation of some i386 packages of wine.. I suggest you some links to follow, hope they might sort you problem. 1.Link 1 2.Link 2 3.Why do I get an “unmet dependencies” error when trying to install WINE? – Saurav Kumar Dec 22 '13 at 5:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.