Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to dual boot Windows 7 64 bit and Saucy 64 bit on a non-UEFI i5 Sony Vaio (except with all Vaio stuff removed) laptop with 8 GB RAM.

This is not my first attempt at installing Ubuntu;

  • I have installed 12.04 using Wubi on the same computer before. After I decided I wanted to move up to 13.10. I went on Windows and deleted my single Ubuntu partition, hoping to be able to easily install 13.10 with Wubi like I had with 12.04, not knowing that the feature had been discontinued.
  • I then used Universal-USB-Installer-1.9.4.2.exe to put the image onto a 16 GB USB drive and booted from it. I ran the install, creating a new ext4 partition from GParted from within the installer (I did not make a swap partition because I figured 8 GB memory should be enough, as the message made it sound like a swap was optional), and encountering no problems. At the end, I restarted like it asked me to, and it did not give the option to boot ubuntu, instead immediately booting 7. After a few f-key mashes, I found that there is not an option for booting ubuntu.
  • So, I tried again after reformatting the partition. Then, after it still didn't work, I tried to run the installer from within the actual demo, but it didn't work and from then on it would no longer boot from the USB.
  • So, then I tried burning the image onto a DVD-R (but it would never burn using the default Windows program, it would eject the disk before starting, so I used WinRAR to extract the .iso onto it) and tried to boot from it, but it never did.

Why, with all of these attempts, did it not work? I'm especially confused about the attempts using the USB, as there were never any issues with the install but it never booted.

share|improve this question
    
Did you ensure GRUB2 was installed to something like /dev/sda instead of /dev/sdaX where X is a number? –  James Fu Oct 24 '13 at 2:20
1  
Wow! This is not a simple question. This is like a "report of a car accident". Have you tried to use boot-repair? Try it and if the problem won't get resolved, give us the URL that this program will produce. –  NikTh Oct 24 '13 at 2:22
    
I don't know how to check anything, as the ext4 partition created during the install is not accessible from Windows. I can confirm the partition exists, using disk manager, but I cannot see what's in it at all. Also, I will have to reinstall it again, as I had killed the last install before attempting the DVD, and I will be unable to do so until tomorrow. –  Toothbrush428 Oct 24 '13 at 2:30

1 Answer 1

I'm also seeing this same issue. Seems to be related to GRUB. I've verified that, at least in the installer, GRUB was set up to install on /dev/sda. I'm installing on a partitioned 256GB SSD hooked up to an ASUS Crosshair V Formula-Z motherboard. The BIOS is set up to use the Legacy ROM, not EFI. Grub isn't running at all on boot, just goes right into windows. Restarted the installer from the Ubuntu 13.10 installer DVD, and verified that the partitions were created, and that Ubuntu installed (about 5GB used of 72GB). I did create a swap partition of 16GB to match the amount of RAM in the system, though I'm not sure that's really relevant to this issue... just mentioning because OP did. I have some older Ubuntu disks around, going to try to install from 12.04 and see what that gets me, and will update this thread.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.