Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install grub-customizer in Kubuntu 13.10. After a lot of fiddling, following various online advice, I got to the point where I needed to install libgtkmm-2.4-dev (which I know nothing about). Here's what I got when I tried:

The following packages have unmet dependencies:

libgtkmm-2.4-dev :
 Depends: libgtk2.0-dev (>= 2.24.0) but it is not going to be installed

 Depends: libglibmm-2.4-dev (>= 2.27.93) but it is not going to be installed

 Depends: libpangomm-1.4-dev (>= 2.27.1) but it is not going to be installed

 Depends: libatkmm-1.6-dev (>= 2.22.2) but it is not going to be installed

And now I can get no further.

share|improve this question
Use Synaptic Package Manager once to install the particular missing packages. Search in synaptic in the reverse order from the list you got in terminal. – Saurav Kumar Oct 24 '13 at 2:19

From apt-get's manpage:

   -f, --fix-broken
       Fix; attempt to correct a system with broken dependencies in place.
       This option, when used with install/remove, can omit any packages
       to permit APT to deduce a likely solution. If packages are
       specified, these have to completely correct the problem. The option
       is sometimes necessary when running APT for the first time; APT
       itself does not allow broken package dependencies to exist on a
       system. It is possible that a system's dependency structure can be
       so corrupt as to require manual intervention (which usually means
       using dselect(1) or dpkg --remove to eliminate some of the
       offending packages). Use of this option together with -m may
       produce an error in some situations. Configuration Item:

Try sudo apt-get install -f then sudo apt-get install libgtkmm-2.4-dev.

share|improve this answer
No joy, alas. Running those two commands still produces the same error. – Paul A. Oct 24 '13 at 5:05
@user101815 How about sudo apt-get install libgtk2.0-dev libglibmm-2.4-dev libpangomm-1.4-dev libatkmm-1.6-dev libgtkmm-2.4-dev? – James Fu Oct 24 '13 at 13:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.